No announcement yet.

unable to run BurnInTest trial in Ubuntu 8.04

  • Filter
  • Time
  • Show
Clear All
new posts

  • unable to run BurnInTest trial in Ubuntu 8.04

    I'm trying to run the BurnInTest trial on Ubuntu 8.04 but the application never opens when I click on the BurnInTest icon or when I try to run it from the terminal. I've gotten it to work in Ubuntu 7.10 but not 8.04. Does BurnInTest Pro support Ubuntu 8.04?

  • #2
    I forgot to mention in my post above that I'm currently using the 64-bit version of Ubuntu 8.04. Not sure if that makes any difference.


    • #3
      Ubuntu uses Gnome i believe, BurnInTest requires some KDE libraries to run so you will need to install the kdelibs package.

      If it still won't run you nca use the ldd command with the BurnInTest executable to display the libraries that are required and which ones are still missing.


      • #4
        After installing the kdelibs I ran burnintest from the terminal and it gave me the following:
        ./burnintest: error while loading shared libraries: wrong ELF class: ELFCLASS64
        Is BurnInTest not supported in 64-bit environments? Thanks for your help.
        Last edited by linuxed; May-04-2008, 10:59 PM.


        • #5
          It seems a number of libraries are still missing after installing kdelibs. Running ldd burnintest displays the following:
     =>  (0xffffe000)
     => /usr/lib32/ (0xf7ef9000)
     => /usr/lib32/ (0xf7e75000)
     => not found
     => not found
     => not found
     => not found
     => not found
     => not found
     => /lib32/ (0xf7e70000)
     => /lib32/ (0xf7e5d000)
     => /lib32/ (0xf7e59000)
     => /usr/lib32/ (0xf7e42000)
     => /usr/lib32/ (0xf7e11000)
     => not found
     => not found
     => /usr/lib32/ (0xf7dee000)
     => /usr/lib32/ (0xf7ddf000)
     => /usr/lib32/ (0xf7cf8000)
     => /usr/lib32/ (0xf7cf0000)
     => /usr/lib32/ (0xf7cd8000)
     => /lib32/ (0xf7cc0000)
     => /usr/lib32/ (0xf7cb8000)
     => /usr/lib32/ (0xf7ca2000)
     => not found
     => /usr/lib32/ (0xf7baf000)
     => /lib32/ (0xf7b8a000)
     => /usr/lib32/ (0xf7b7f000)
     => /lib32/ (0xf7a2f000)
     => /usr/lib32/ (0xf6f1a000)
     => /usr/lib32/tls/ (0xf6f18000)
              /lib/ (0xf7fb1000)
     => /usr/lib32/ (0xf6f15000)
     => /usr/lib32/ (0xf6f13000)
     => /usr/lib32/ (0xf6efb000)
     => /usr/lib32/ (0xf6ef5000)
          I'm in the process of installing the missing packages. I'll let you know if that fixes it.


          • #6
            Well, none of the missing libraries seem to be available. I tried running sudo apt-get install [NameOfPackage] for each missing library and each time it returned not found. Where can I get those libraries?


            • #7
              It's possible that as you are running 64bit Ubuntu it only installed the 64 bit version of kdelibs, as the package manager might only install 64 bit libraries.

              Or it might be that the libraries are there but as mentioned on this page ( Ubuntu didn't create the links properly. You should be able to check this by seeing if there is a /usr/lib32/ and manually creating the link to /usr/lib32/

              Only the command line version of BurnInTest has a 64bit compile, the GUI version is currently 32bit.


              • #8
                As it turns out the 32-bit libraries were not installed. After manually extracting a few files to the correct location I was able to get burnintest up and running successfully. So for anyone else who has run into this same problem I've listed the steps below on how to fix it.

                1. Download the i386 versions of the files you are missing. In my case it required the following 3 packages.


                2. Run file-roller as root so you can extract the files to /usr/lib32

                gksudo file-roller

                3. Open each package and select the files to extract.
                4. Extract the files to /usr/lib32
                5. Run burnintest.

                List of files that I extracted to /usr/lib32: