No announcement yet.

Burn In Test only reads and writes to memory as root

  • Filter
  • Time
  • Show
Clear All
new posts

  • Burn In Test only reads and writes to memory as root


    We are working on making our linux distro auto login and run Burn In Test on start up. We are experiencing a couple of issue with this. The first(MAIN) one concerns Burn In Test not allowing us to access /dev/mem in order to test memory. The only way this will work is the by logging in as root. This issue is KDE does not allow for root to log in automatically. We have tried changing permissions of /dev/mem and tried add the user to both the root and kmem group to allow access to /dev/mem. However, this has proved to be unsuccessful. Any advice would be extremely helpful.

    Thanks alot!!

  • #2
    You could try adding the user to the sudoers file (/etc/sudoers) and executing BurnInTest with the sudo command, this should allow it to run with admin permissions (this is required for the memory test as BurnInTest needs to allocate and lock a large amount of memory for the test).