No announcement yet.

Burn In Test v7 - Running from Bootable CD

  • Filter
  • Time
  • Show
Clear All
new posts

  • Burn In Test v7 - Running from Bootable CD


    I've managed to build a bootable BART-PE CD but I'm encountering an error message when I run BiT.

    "Error loading Error Classification file: line beginning 0
    Some Error text and classifications will be undefined."

    I'm guessing this is because BiT is not finding the 'BITErrorClassification.txt' file in the 'default directory', so I have tried the -P switch, which does not seem to have any effect.

    Any help would be great, many thanks...
    Last edited by netdude-uk; Mar-12-2012, 04:01 PM. Reason: Extra info!

  • #2
    The 'BITErrorClassification.txt' file must be included in the same directory as bit.exe. The -p command line parameter will have no effect on the required location of this file.

    Another possibility is that the 'BITErrorClassification.txt' file is corrupt. I would get a new copy from a fresh install of the latest version of BurnInTest:

    FYI, the recommended mechanism to build a boot optical disk or UFD with BurnInTest 7.0 is to use WinPE. Please see our guide here:


    • #3
      I did try following the WinPE setup guide, but did not have much luck, and made several coasters. The coasters were most likely caused by me and not your guide.

      I used the WinPE guide to assist me with building a BartPE CD (which worked first time, but with a few errors). This is the last error, which should be the simplest to overcome, but I'm really struggling...

      At the moment I have BiT located in the root directory of the bootable CD, along with the BITErrorClassification.txt file. If I use the command prompt, CD to the root directory and run BIT then I encounter this error.

      Before prepping the CD, I have used the BiT -> Install BurnInTest to a USB drive, with the license key entered.

      Before compilation onto the bootable CD, BiT runs fine from the USB Drive without error, so this indicates that the BITErrorClassification.txt file is intact (and also the license information).

      I then use PE-Builder (v3.1.10a) to include the BiT folder from the USB drive when compiling the bootable CD.

      The only difference I can think of between the two file locations is that on the USB disk, the file can be written to, but on the CD obviously it cant... Does BiT try to write to the file on start up?

      The strange thing is, if I allow BiT to run, get the error, then select Configuration -> Edit Error Classifications... then I can open the file with no problems at all and check the contents... Weird?

      I intend to run BiT from the command prompt, so is there a switch or another way of directly specifying the BITErrorClassification.txt file at startup?

      Any more ideas would be greatly appreciated...


      • #4
        We have not tested BurnInTest v7.0 on BartPE, but rather on WinPE.

        BurnInTest v7.0 does not try to write to the BITErrorClassification.txt file. The error you get, "Error loading Error Classification file: line beginning 0", shows that no lines where read from the file, almost certainly it could not be opened. So it is strange that Configuration->Edit Error Classificaitons can open the file.

        I would make sure you have the latest build of BurnInTest v7.0.

        I would try WinPE with a bootable UFD (no coasters and can write configruation files, log files etc).


        • #5
          Thanks for the suggestions...

          I'll download the latest version and try that - It is slightly newer than the one I'm using currently.

          I'm gonna stick with BartPE for now as I'm sooo close, and going back to WinPE would mean starting from square one again.

          I'll let you know what happens, good or bad... Thanks again.


          • #6
            No luck - I tried the latest build (1009), but no difference...

            Interestingly, if I boot from the CD, I get the usual error. But then after CD bootup, if I run BiT from it's original installed directory (C:\BurnInTest\) it works fine.

            It's as if the BiT installed on the USB Disk / CD is still looking for source files in C:\BurnInTest\

            When booted, my CD root folder shows up as X:\ so maybe this is the 'root' (ahem ) of my problems...

            I still have the errors, and BiT runs fine, so I can get on with some testing.

            I'll come back to setting up a pucker boot CD when I have more time.

            Thanks again for your help...