No announcement yet.

Burnintest Linux 4.1 1000 Sound Test

  • Filter
  • Time
  • Show
Clear All
new posts

  • Burnintest Linux 4.1 1000 Sound Test

    I'm currently having an issue running the sound loopback test.
    Everytime I start the test, I get the error "Unsupported Waveform audio format for output device".

    I was looking for similar issues from other users, but it doesn't seem like there is much information.
    I ran the command "speaker-test -c 2 plughw" and had no issues with the sound output.

    I have also tried to set other device names such as "default" instead of plughw, and still run into the error in burnintest.

  • #2
    Usually if the speaker-test command works then BurninTest should work, but to put it bluntly the sound sub system in Linux is an absolute mess and there could be some other sound mixer setting or driver setting causing problems.

    Could you please launch BurnInTest in debug mode, using the command line paramter -d, try to run the sound test and then send us a copy of the debug.log file that is created.


    • #3
      Do I run this only in cmd line mode? Or can I also run this in gui mode?

      I also noticed that in gui mode, the window that pops up for the sound test looks corrupt or fragmented.


      • #4
        GUI or command line is fine, the underlying test is the same but the GUI version displays a visual representation of the sound quality of the recording.


        • #5
          I looked at the debug file and found out the device resource was being taken up. I ended up restarting the device and it works when I run the test by itself.
          However now I am having trouble with the test not starting when I run all of the other I/O devices with it. Currently trying to run CPU, RAM, 8x USB 3.0 Loopbacks, 2x COM Ports, and the Sound Loopback test.

          all of the other test are starting EXCEPT for the sound test now.
          But if I turn off all the other devices, the sound test can run on its own. Is this a bug or limitation with the linux burnintest?


          • #6
            After more testing, it looks like whenever I run the "RAM" test with the "Sound" test, it will stop the sound test from running.


            • #7
              There aren't any known issues that would stop the sound test working in conjunction with the RAM test, it may be on your system the RAM test is allocating too much RAM or there are some device driver leaks causing the amount of available free RAM to be less than it should. Could you please email us the debug log so we can take as look at it as well as the hardware specs for the system.