No announcement yet.

Flash driver test

  • Filter
  • Time
  • Show
Clear All
new posts

  • Flash driver test

    Hello Sir,

    I am using BurnIn tool for testing Flash drive. I run this application on 128MB and 256MB Flash for 12hrs(tested on windows2000 and windowsXP), it is giving different error for different OP.

    test file could not be created. check access privilage - windowsXP
    error while reading from the disk - windowsXP
    seek size requested not equal to actual - windows2000

    What is the reason for getting these errors?


  • #2
    Generally speaking, the errors mean:
    1) test file could not be created. check access privilege - windowsXP
    ->> Can't create a test file. The location depends on the version of BurnInTest.

    2) error while reading from the disk - windowsXP
    ->> Can't read a block of test data from the test file (that is open for testing).

    3) seek size requested not equal to actual - windows2000
    ->> During the Random seeking test there is an error moving to a random position on the disk (flash drive). This test can be used on a flash drive, however it is worth noting that it was designed for HDD's.

    I suspect that the different behavior between the different Operating Systems is related to the Device driver behavior (possibly in providing 'dummy' disk geometry data). I would try the disk test without the seeking test (i.e don't use Cyclic, Random seeking or butterfly testing) to see if you still get errors.

    A trace 2 level log file will contain more specific information about these errors. If you would like more specific information please email a .trace file showing these errors to help [at] passmark [dot] com

    Ian (PassMark)


    • #3
      Thank you sir



      • #4
        Dear Ian,
        Can you elaborate on 'dummy' disk geometry data or direct me to the proper documentation? The company I am with recently purchased BurnInTest V5.3 Professional Edition and we are seeing the following error, "Unable to get disk Volume extent information."

        The above error occurred on 1 of 3 flash drives that were undergoing burn-in test. The 3 drives are built exactly the same (same PCB board, Controller and Flash IC). I noticed a test file remains in failed drive. I get the same behavior when runing Microsoft's ReadyBoost test in Vista OS. Failure states, "Failed to properly assess the disk," and only happens during the random write test operation.

        Thank you for your assisstance.

        Best Regards,


        • #5
          The Butterfly seek test was designed for Hard Disk drives and seeking between different cylinders on the hard disk.

          To run the Butterfly seek test BurnInTest needs to be able to get some system information about the physical disk:
          (1) Volume (drive letter) to physical drive(s) mapping
          (2) Physical disk geometry (size, number of cylinders, tracks per cylinder, sectors per track, bytes per sector).

          This information is obtained from the Disk device driver. In some cases device drives of USB flash drives return data that is clearly not the number of cylinders (this is what I meant by dummy) while in other cases the information is not available.

          If BurnInTest is unable to retrieve the information the following errors are displayed, respectively:
          (1) Unable to get disk Volume extent information.
          (2) Butterfly seeking test not supported for this disk.

          So in your case BurnInTest failed to get the Driver letter to physical drive mapping and was unable to run the test (rather than a write, read or validation error). I would suspect the drive format FAT32,NTFS may be different on the drives or the device drivers loaded are different or behave differently under some condition. You can get more detailed error information by setting level 2 activity trace logging.
          I am a bit surprised that you say that the error occurs during the random write test operation as the error should only ever be generated during the Butterfly seek test.