No announcement yet.

Burn-in Pro 5.3 - multi port usb testing

  • Filter
  • Time
  • Show
Clear All
new posts

  • Burn-in Pro 5.3 - multi port usb testing

    platform P-IV 3.2, OS WinXP,USB2 test plug, Industrial computer with 6 USB ports.
    When testing a single USB port all is O.K
    When trying 2 and more ports onlt 1ST. port work O.K all others are not
    working properly, most are stuck at 181248 operations with common error
    :USB data packet verify failed
    Data packet transmission failed (Code 0) [Serial#; PMLU8H4S]
    CRITICAL : 2007-04-17 08:59:06, USB, Could not detect USB loopback plug
    We used latest USB drivers from your Web 6.1.1
    When we connect 4 test plugs through a USB Hub all works O.K
    Please advise
    Your prompt reply will be appreciated

  • #2
    My guess is that this motherboard doesn't provide enough power to run this many USB devices at the same time. How big is your power supply and how many watts is it rated at for the 5V rail?


    • #3
      we use a 300W P.S (FSP300-60PLN) with 5VDC 30 Amps.
      When we used the Hub it was a passive one ( no external P.S ) and all 4 plugs worked O.K so it looks like
      we do not have a power problem , but still if we plug 4 units to 4 ports only one is working.
      We can also see that sometime the SW do not recognize all 4 plugs but only 3 or 2, and during
      the test they tend to work randomaly and you can see that the operation counters are increment.
      Last edited by ytirosh; 04-18-2007, 10:01 AM. Reason: add on info


      • #4
        Are you using our PMUSB02 (rev1) device or PMUSB02 (rev2) device? The newer Rev2 device uses less power.

        It is also possible that the hub placed the USB plugs into low speed mode in order to use less power.

        Or that only some of the USB ports on PC are lacking in power. Did you try the hub on all ports of the PC?

        If you can, I would also try the same test on a standard desktop PC.

        If the the plugs are working with the hub, and on other PC, and you are sure your cables are OK, then the next most likely possibility is that your motherboard is bad.


        • #5
          We use PMUSB02 (rev 2 ) purchased 2 weeks ago (Arrow/Rapac LTD).
          We tried on standard PC but same results.
          We will try hub on all ports but it looks like this is not the issue.
          do you have similar problems from other customers?.
          We tried on 2 PC's with different MB's from 2 vendors ( Advantech & Supermicro ) with same bad results.


          • #6
            We tested BiT 5.3 with 5 USB2 plugs on 5 different USB ports without any problems. Have you tried varying the load for the USB test, the higher loads are very CPU intensive.


            • #7
              We have not had this specific problem reported from another customer.

              The only problem reported that I think could possibly be related was one customer that had a problem with electrical interference on a particular USB port (common hardware issue on this type of custom motherboard) and when a USB 2.0 Loopback plug was connected to this particular port (and another device was also connected to the bus) and was loaded with traffic, the behavior was pretty much undefined, from write failures (in V4 of BurnInTest, this was actually seen as a lock up in BurnInTest), also plugs could become 'undetected'. We spent a lot of time with this hardware and as a result modified BurnInTest V5 to better report this type of hardware problem (e.g. Reporting USB host controller errors).

              Could you please do some tests and email the results:
              1. Run the USB2Test.exe application on each USB port and let me know whether there are any “Device transceiver errors”?
              2. Run BurnInTest with 2 USB plugs with logging set to Level 2 trace logging set on. Please send me a .trace log showing the errors.
              3. Repeat 2, with 4 USB 2 plug.

              Is there a common hardware component between all of the systems you are using and having problems with, e.g. Motherboard, USB enhanced Host Controller type?

              Do all USB 2.0 Loopback plugs have the Orange LED on when testing?

              Please send the results to help [at] passmark [dot] com.


              Ian (PassMark)