No announcement yet.

USB 2.0 LoopBack Plug Error In Windows 10

  • Filter
  • Time
  • Show
Clear All
new posts

  • USB 2.0 LoopBack Plug Error In Windows 10

    I have one of your USB 2.0 Loopback Plug that I bought years ago (30 April 2004, Order #: U5729799). Not sure what Rev. it is, on back in only says Model: PMUSB02. I cannot get it to work on my Windows 10 computer (Windows 10 Pro 64bit all updates). When I install the drivers for it I get some I get some kind of driver is corrupted or not for Windows error. I have attached 2 pics of the error. I am not really sure if the USB 2.0 Loopback Plug works with Windows 10? I have one of your USB 3.0 Loopback Plugs and it works fine on the same computer. I have redownloaded the drivers twice. Thanks for any help.

    "Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)"

    Click image for larger version  Name:	USB 2 LoopBack 2.png Views:	10 Size:	19.7 KB ID:	51342Click image for larger version  Name:	USB 2 LoopBack 1.png Views:	9 Size:	16.6 KB ID:	51343

  • #2
    Yes, we are still selling the same USB2 plugs and they work in Win10.

    Are you sure you are not mixing up the 32bit and 64bit device drivers?
    The drivers for the USB2 and USB3 plugs are not the same, are you sure you are using the USB2 drivers with the USB2 plug?


    • #3
      I tried both the 32bit and 64bit drivers. In fact it would not let me install the 32bit drivers. And yes, I am sure drivers the are for the USB 2 Plug. I downloaded them twice to make sure and that I did not get a corrupt download. The file name is I did notice the drivers are kind of old, back from 2011. That's why I thought they did not work with Windows 10.

      Thanks for help...


      • #4
        I tried it on another computer and the driver loaded fine and the USB 2 Plug worked correctly. But I did fined out what the problem was. On the computer that the driver would not load correctly I had Memory Integrity turned on (Settings, Update & Security, Windows Security, Device Security, then Core Isolation). I turned that off and the driver loads fine. But I can't turn it back on without uninstalling the driver. I know it is not a very high priority, but maybe an updated driver someday.

        Thanks for Help.....


        • #5
          Thanks for the follow up and solution. We aren't aware of this issue. It seems this setting is off by default in Win10.
          It also isn't clear how Windows determines if a driver is compatible with this Memory Integrity feature. It might just be a packaging issue.

          That error message, "driver may be corrupted or missing", is super mis-leading however. As it is neither corrupt or missing.

          Being USB2, it is an 18 year old product now. So unless it totally stopped working on a default Windows, we probably won't go back and modify it.
          (Note that for Windows 11, this might happen).


          • #6
            Yes, that settings is off by default. I have seen something like this before with older drivers. Not sure what is missing, but it seems to be drivers that have not been updated for awhile. Saw it with the WD Passport driver and a driver for a Brother printer. Even though they were Windows 10 drivers, they were pretty old. Anyway, thanks for the info....