No announcement yet.

MemTest86 errors with Celeron N2840, ASUS X551mav

  • Filter
  • Time
  • Show
Clear All
new posts

  • MemTest86 errors with Celeron N2840, ASUS X551mav

    Basic PC: Celeron N2840 @ 2.16GHz, HDD, 4GB RAM ddr3l @1333MHz, CL9 dram freq= 667.8MHz, 1.35v. HDD tests perfectly. No clock or voltage settings avail in BIOS. MemTest86 on single 4GB RAM yields 6 errors on 13 tests, 4 passes= 24 errors total. Replace single 4GB stick with new single 8GB stick. Run MemTest86 again: results identical, with all 6 errors/ pass in same places. PC runs fine with either stick, ie would not have noticed anything if MemTest86 was not run. Any thoughts or comments on what might be going on??

  • #2
    Can you post the details of the errors.

    Might be a BIOS firmware bug. Sometimes bad BIOSs say a block of RAM is free, when it is already in use by some piece of hardware. So two different processes (MemTest86 and some random bit of hardware) are using the same RAM at the same time. Leading to corruption.


    • #3
      I have some "screenshots" which may help. To summarize situation: PC came with 4GB RAM 1 stick, so before I upgraded it to 8GB 1 stick I ran both "Windows Memory Diagnostic" as well as "MemTest86" on the 4GB prior to removing it and then on the 8GB after installing it. Neither the 4GB nor the 8GB have ever given me any recognizable issues, so the RAM tests were just out of curiosity. Results were: Original 4GB had zero errors on WMD, but showed 6 errors on each pass of MT86, for a total of 24 errors on the 13 test 4 pass session. Lo and behold, the new 8GB had exactly the same results, ie zero errors on WMD, and 6 errors on each pass of MT86, for a total of 24 errors on the 4 passes. Too much of a coincidence to assume bad RAM??? Perhaps there is a clue in the test result screenshots?? WMD = 0 errors for both RAMs, 2 passes. Screenshots for MT86. Thanks. MAX 3 ATTACHMENTS PER POST, SEE NEXT 2 POSTS, AS THERE ARE 9 ATTACHMENTS.
      Attached Files


      • #4
        Continuing, with next 3 attachments.
        Attached Files


        • #5
          Continuing, with final 3 attachments.
          Attached Files


          • #6
            Yes, it seems very likely it is a UEFI BIOS bug on this machine.

            Three points.
            1) The memory addresses in error were very low in the memory address range (all under 1MB)
            2) The BIOS memory map reports that the memory address range from address 0 to address 0x8EFFF is free and available for use. This is surely bollocks, as these low addresses ranges are nearly always in use by other hardware (see memory mapped I/O).
            3) There are lots of bits in error, 0xFF, which is 8 bits. Having single bit errors is more common when the RAM is at fault.

            Looks similar to the problem in bug in Apple's OS X 10.13 bootrom.

            What is the make and model of the machine? (in case other people have the same problem)


            • #7
              Thanks for your response. PC is: ASUS X551mav. As I am not well-versed in this topic it will take some time to fully digest what you said above, but I think at this moment I have the essence of what you mentioned. I will study the subject further. For now, may I ask the following: Does it make any sense to disconnect the internal sata HDD, and disconnect the internal sata DVD drive,
              and then run MemTest86?? Will it run, and will it tell us anything, as only mboard and CPU and BIOS are remaining culprits, ie no other hardware involved?? Second question: BIOS mode in this PC is UEFI ENABLED, and therefore I assume I ran correct version of MT86, however, BIOS has never been upgraded; if there is some issue with BIOS, would an upgrade (reflash) serve to correct the problem?


              • #8
                Yes I BIOS update might help.
                Otherwise ASUS really need to fix the bug.