No announcement yet.

Inconsistent Memtest86 results?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Inconsistent Memtest86 results?


    A few weeks ago, I built myself a new PC. Here is the full parts list: So the build runs fine for the first few days, however, while playing Siege, my computer completely froze up (except for the audio still playing) and essentially forced itself to reboot. This only happened once while playing video games (Siege only crashed to desktop but never caused my entire PC to freeze up). I checked to see if the problem was heat related, which was not the case and thoroughly checked for any errors or if my Windows 10 install was corrupt. Everything checked out and I simply thought it was a one time thing maybe related to Siege itself. However, a few days later, the same thing happened while watching a video on Chrome, which was pretty much the only program running at the time.

    So I began stress testing the CPU and GPU, all of which came back fine and didn't cause any crashes or freezing. Up next, I tried Memtest86, which resulted in ~45 errors all on Test 8, however it froze up on Test 7 on the third pass. I began testing only one stick running only on single core (I read that Memtest86 freezing was probably due to problems with Memtest86 running on all cores) and it passed, as well as all 4 sticks on single core. However, when I went back to running all 4 sticks on all cores and it surprisingly ran all 4 passes with no errors at all. I figured that maybe I didn't seat the RAM properly or there was some dust in the slots.

    I ended up opening an RMA with Corsair a few days before getting no errors on the last test, thinking that the RAM was likely faulty. I threw the replacement RAM just to see if it would give any errors, and lo and behold it did, but this time a few errors on Test 6 and a lot on Test 8. I ended up testing one stick on the first slot with no errors, and the same stick on the second slot, again with no errors. Oddly enough, I was unable to boot up the PC with a single slot on slot 3 or 4, so I resorted to running a test only with sticks on slots 2 and 4, which ran with no problems. I reran all 4 sticks again and I was shockingly frustrated to see no errors.

    At this point, I'm pretty confused on why some times I get errors and some times I don't. I suspected that maybe my motherboard is bad or has a bad cap, or maybe something funky is going on with the BIOS. During the entire time running Memtest86, the BIOS was up to date and has not been flashed. Other things I can think of is maybe a bad PSU or USB port on the case? But I felt that those are highly unlikely especially with the PSU, given that my PC only hard rebooted twice and not once ever since running Memtest86 (almost as if the problem hid itself once it saw me running it).

    I'm hoping I can get some guidance as to what is going on with my PC before I go ahead and RMA half the parts in it.

    Thanks in advance for reading this lengthy post and helping!

  • #2
    The lockups with multi-threading are due to UEFI BIOS bugs. But any lockup nearly always happens in Test 1 or 2 during the first pass and it is very repeatable. (i.e. very early in the testing process and consistent). Also these UEFI threading BIOS bugs don't cause memory errors.

    So likely the RAM was actually bad. Maybe all those re-insertions fixed it? Or maybe it is a combination of particular sticks in particular slots?


    • #3
      I'm just confused on the new RAM producing errors and now not showing any. After testing with one and two sticks, the order of the sticks in the slots changed, so it seems likely that it may have been faulty RAM. I'm not sure if the motherboard is faulty as well given that errors were produced even on new sets of RAM. Or maybe the memory controller on the CPU is at fault. I'm not sure if the errors produced half the time warrants which part to RMA or if I should RMA any part at all, since I don't have spare parts or anybody with spare parts to test with either.