No announcement yet.

MemTest86 v6.0 Beta (2015-02-13 Update - Beta testing is now closed)

  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    I know that MemTest86 v6 beta is unsigned, but can i put Secure Boot keys myself, and how to do that since I can insert the UEFI keys myself (ASUS Maximus GENE V)?


    • #32

      Most BIOSs allow you to turn secure boot off.
      But otherwise I don't think there is anything that can be done. We'll be doing a beta 3, then getting the release signed.


      • #33
        I know I can turn secure boot off. OK thanks, just asking cause it's a pain to turn off every time, and I like the added security so I use it...
        Was just asking if there was a key to insert myself, but I understand it is just a beta.
        Thanks for the answer!


        • #34
          Hammer Row Test Errors

          Using MemTest86 V6.0 (Both Beta 1 and 2) I am getting errors after about 19% into the Row Hammer test.

          I also have a Diag. program called PC-Check V8.02 by Eurosoft. I sent them some email asking if they were going to add the Row Hammer test to their program as part of the memory test. I got this reply back:

          Pc-Check Microtopology Memory Test covers reporting on the Possible Row Hammer problem. It will report as a Coupled Bits Detected error.

          My computer passes the Microtopology memory test in PC-Check just fine. My question is, which test is right? MemTest86 V6 where it fails or PC-Check where it passes?

          Are there any settings, like in the BIOS I could change to possibly make the memory pass the Row Hammer test in MemTest86 V6?

          I have an Intel DZ77RE-75K motherboard with a Intel i7 2600K CPU. 32GIG of Muskin DDR3 Memory 933.3 MHz (DDR3-1866 / PC3-14900).


          • #35
            There are different ways to implement a row hammer test. The optimal algorithm for exposing errors varies depends on the CPU, motherboard and how much RAM is installed (and if it is dual channel mode).

            So slight algorithm and timing differences can expose different faults.

            There is nothing you can change in BIOS to fix this. But dropping out of dual channel mode might hide it.

            V5 of MemTest86 doesn't have a Row hammer test, so it should pass that version.

            My own PC actually fails the row hammer test, but only with a single error, and it is stable 99.9% of the time. So if you have a very small number of errors and the PC isn't being used for anything critical, I think you can ignore them.


            • #36
              MemTest86 6.0 Beta 3 release

              MemTest86 6.0 Beta 3 is now available for download from the MemTest86 download page.

              Changes since Beta 2 are as follows.

              New Features

              • Added translations and language options for French/German/Japanese/Chinese


              • Fixed freeze during initialization of ECC support for Intel E5 v3 (Haswell) due to reading from non-existent MSR register
              • Fixed freeze on systems that use older UEFI firmware (such as Mac) that do not support string packages and fonts using the Hii Database. These systems may have limited language support, however.
              • Changed minimum resolution to 1024 x 768
              • Fixed Main Menu text being overlapped on some systems
              • Various system info related fixes (SPD, CPU)


              • #37
                If your memory fails the row hammer test, is it always the memory causing the error or could it be the motherboard (like the memory controller, etc..)?

                On Beta 2 and 3 (not sure about Beta 1) under System Info for CPU Clock it shows 3392MHz [Turbo: 3472.1MHz]. Since I have an Intel 2600K, shouldn't it show somewhere around 3.8MHz for Turbo?

                On Beta 3 I am getting garbage on the screen when I go back to a previous menu or choice. Example, When MemTest86 is running the memory test and I hit the ESC key and then choose go back to main menu, it's like it doesn't clear the screen. I see leftover parts of the memory test screen. I have an Nvidia GeForce GTX 660 video card. This didn't happen in Betas 1 and 2.

                Thank you for your time...


                • #38
                  The row hammer test is designed to expose disturbance errors within the RAM modules itself, independent of the memory controller. However, if there is an issue with the memory controller, you may still see errors in the row hammer test (as well as the other tests)

                  On Beta 2 and 3 (not sure about Beta 1) under System Info for CPU Clock it shows 3392MHz [Turbo: 3472.1MHz]. Since I have an Intel 2600K, shouldn't it show somewhere around 3.8MHz for Turbo?
                  MemTest86 attempts to measure the turbo speed by enabling turbo mode and putting the system under load, in hopes of approaching the theoretical turbo speed. However, for whatever reason, sometimes the system doesn't reach the higher power state that will force the CPU to run at the turbo speed. If you have the log file, we can take a look to see what is happening when the measurements are being taken.

                  On Beta 3 I am getting garbage on the screen when I go back to a previous menu or choice.
                  We aren't able to reproduce it on our systems, but we made a few changes that may or may not fix the problem. Can you give this build a try:



                  • #39
                    Is memtest86 6.0 beta supposed to display a completely different version number? I see it displaying version 4.3.7. as it runs.


                    • #40
                      The MemTest86 v5/v6 images are dual-boot, meaning that both the BIOS version (v4) and UEFI version (v5/v6) are packaged into a single image. If your system is unable to boot in UEFI mode, it will boot the older MemTest86 v4 as it appears to be happening in your case.

                      There may be several reasons why MemTest86 v6 isn't booting, including:
                      - System does not support UEFI
                      - System is not configured to boot in UEFI mode
                      - SecureBoot is enabled (v6 beta is not signed, so it will fail SecureBoot check). The final V6 release will be signed.


                      • #41
                        I have log file but cannot find a way to attach it to this message. Can you tell me how or tell me where to email it to?

                        I tried the new build from the link you sent me. Still getting garbage on screen but it may be a little different. When MemTest86 first boots up the screens are fine. Run the mem test, hit ESC and go back to main menu and at first it looks ok, but the last option "Save system information summary to file" is like at the top of the screen at the left. Then when I move the mouse pointer or select one of the options (like CPU selection, etc...) it starts making garbage on the screen. Like the mouse cursor messes up whatever it touches or if I select one of the options, it doesn't clear the screen before showing the new screen. However, if I select "Start Test", that screen shows fine. It's kind of like I am getting that "Fixed Main Menu text being overlapped on some systems" that was one of the fixes in Beta 3. Like I said, this does not happen in Betas 1 and 2.

                        Thank you for your time....


                        • #42
                          This may help on the garbage on screen problem I was having with Beta 3.

                          I noticed on Beta 2 the Exit option never appears on the Config Screen. ( the screen that has the Start Test, Select CPU, etc.) even though it's there I just can't see it. Guess the screen resolution is not correct. But I never have the garbage on screen problem with Beta 2.

                          On Beta 3 I can see the Exit option on the Config Screen when I first go into it. OK, seems the screen resolution is smaller now. However, run memtest, hit ESC and then go back to main menu and I can't see the Exit option anymore. It's like it is not switching back or staying in the correct resolution.

                          I have an Intel DZ77RE-75K motherboard with a Intel i7 2600K CPU with a Nvidia GeForce GTX 660 video card.

                          Thank you for your time..


                          • #43
                            Contact details for sending logs is here.


                            • #44
                              Not sure if you got my reply to your email, but the latest build of Beta 3 ( seems to have fixed the video problem. No more garbage on the screen and the resolution is right and stays right.

                              I have one question. When Memtest86 is running the memory test it shows the XMP profile (settings for memory) for the memory instead of what the memory settings are in the BIOS. Is Memtest86 running the memory test with the XMP settings or with whatever the memory is set to in the BIOS? I ran Memtest86 on another computer and it too show the XMP
                              profile settings for the memory even though it's not set at that.

                              Thank you for your time...


                              • #45
                                The current BIOS speed settings are used for testing. MemTest86 doesn't attempt to modify the BIOS settings.

                                However for the system information display, the best speed setting is displayed. This is still the case even if you aren't running at the best available speed. The best setting typically also corresponds to the marketing specification. (i.e. it is what people expect to see as a description of their hardware).