No announcement yet.

A problem with OSFMount on Win7 Professional 64bit.

  • Filter
  • Time
  • Show
Clear All
new posts

  • A problem with OSFMount on Win7 Professional 64bit.


    I met a problem with OSFMount on Win7 Professional 64bit.

    Install file was downloaded from URL:

    After installation, I tried to mount attached IMAGE file (EXT2), but it seems that the file canít be recognized normally.
    (File system is N/A.)

    Also, when I tried to open F driver, error dialogue displayed notifying that the driver canít be recognized.

    With the same IMAGE file, it can be mounted successfully under Windows XP environment by OSFMount 32bit.

    Would you please give some advice for this issue?

    the image create by:

    # dd if=/dev/zero of=disk.img bs=1M count=10
    # mkfs.ext2 -F disk.img


    Best Regards,Baiyu

  • #2
    Currently, OSFMount does not support any file system that Windows does not support. OSFMount simply creates a virtual disk backed by the contents of the image file. It is up to Windows file system drivers to recognize the file system on the image. So I find it odd that you were able to mount an EXT2 image on Windows XP. Perhaps there is a 3rd party EXT2 driver installed on your XP system?

    Anyways, we are looking at support for non-Windows file systems for a future release.