No announcement yet.

:OSFMount: CLI mounting without drive letter

  • Filter
  • Time
  • Show
Clear All
new posts

  • keith
    Since the official release of OSFMount v3, mounting using Physical Drive emulation via CLI is now supported.

    OSFMount shall automatically mount using Physical Drive or Logical emulation based on whether the image file contains a partition table or not

    Code: -a -t vm -f "C:\LocalVMStorage\Virtual Hard Disks\transcode.img" -o rw
    Assuming transcode.img contains a partition table, the above command shall mount the image as a physical drive (using the next available physical drive number)

    Leave a comment:

  • JimmyGuy
    This would be a great feature (mount using Physical Drive emulation at the command line). +1 on this request. Thanks!

    Leave a comment:

  • keith
    At the moment, OSFMount V3 beta CLI (command line) does not support mounting using Physical Drive emulation. So it needs to be done in the GUI.

    We hope to add that to the CLI in a future beta release.

    Leave a comment:

  • hendryjl
    started a topic :OSFMount: CLI mounting without drive letter

    :OSFMount: CLI mounting without drive letter


    I'm stuck trying to do something via the CLI that I can do from the GUI just fine, I am attempting to use the CLI to create a new ram drive that's using physical disk drive emulation, with a drive type of HDD, from an IMG.

    Using the UI, I create it by doing:

    * Disk Image File (point to an IMG file on the local machine (created in previous OSFMount session and saved)
    * Check the box for Mount as RAM drive

    Step 2:
    * Choose mount entire image as virtual disk

    Step 3:
    * Don't select anything

    Step 4:
    * Unselect Read-Only Drive
    * Drive Emulation: Physical Drive Emulation
    * Drive Type: HDD

    Once I do this, it works perfectly. I've tried to do the same with the CLI and this is as close as I've gotten:

    If I do this: -a -t vm -f "C:\LocalVMStorage\Virtual Hard Disks\transcode.img" -o rw

    It tells me a drive letter must be specified.

    If I try one of these: -a -t vm -f "C:\LocalVMStorage\Virtual Hard Disks\transcode.img" -o rw -m "\\.\PhysicalDrive1" -a -t vm -f "C:\LocalVMStorage\Virtual Hard Disks\transcode.img" -o rw -m #
    I get a message saying that junction points aren't supported.

    I know that I can make this work manually/GUI. Is there a combination of switches to do this via the CLI? I've also tried adding to the -o fix and hd (from release notes) options.

    I'm using the latest beta version.

    Thanks in advance!