No announcement yet.

PCI-e Test Card and Intel ME

  • Filter
  • Time
  • Show
Clear All
new posts

  • PCI-e Test Card and Intel ME

    I was running PCI-e tests on some similar devices and on one of the the PCI-e test software (nor burnintest) would not get any temperature / voltage information from the test card. Loopback tests failed as well.
    After some wondering I noticed Intel ME was not disabled on that device, like it was on the others. disabling ME allowed me to run the tests.

    Are there known issues with Intel ME and the PCI-e tests?
    I'll try to give more details if needed.

    Fortunately we usually disable Me since it's rarely used.

  • #2
    No, we aren't aware of any compatibility problems with our PCIe test card and the Intel Management Engine. (As an aside Intel ME it has been in the news a lot recently as it has a security backdoor, so turning it off might be a wise thing anyway).

    What are the specs of the machine (CPU & Motherboard model) and which O/S are you running?


    • #3
      Seems this could be genuine hardware issue we have with this system. Tried reproducing the issue today and just enabling ME didn't actually bring the issue back.

      To reproduce it I had to remove the test card, flash BIOS and after that install the card back. After this I got the errors again (PCIe data transfer error: 4080 of 4096 bytes incorrect) and no temp or voltage readouts.
      I also tried disabling AMT from BIOS after this, which didn't help. There's a jumper to disable ME on this board and that fixed the issue again.

      I'll take this issue to the motherboard manufacturer. Seems like some sort of conflict with PCIe devices.


      • #4
        Would still be interesting to know the motherboard model, just in case someone else encounters the same problem.


        • #5
          Motherboard is MSI MS-98B7 PICMG 1.3 SMB. Chipset is C226. We're also using our own custom back plane for it so it can be part of the issue as well.
          Somewhat special case.