No announcement yet.

WinPE Builder error 1 / error 10

  • Filter
  • Time
  • Show
Clear All
new posts

  • WinPE Builder error 1 / error 10

    Sometimes when creating a self booting USB using WinPE Builder the process may fail with the error "error building winpe image (10)" or "makewinpemedia failed error level 1".

    makewinpemedia is Microsoft's software for preparing the drive. It isn't very tolerant of different drive configurations on USB flash drives.

    This error will usually mean there is an issue with the partition on the USB drive and makewinpemedia cannot use the partition;
    • The partition is too big to be formatted with FAT32.
    • The USB drive is using GPT instead of MBR for the partition table. But MBR is also limited to 2TB drives.
    • There is an unknown issue with the current partition preventing access
    • For unknown reasons, small USB drives have been observed to give less trouble (<32GB).
    This error can usually be fixed by removing and recreating the current partition in the diskpart tool accessed via a windows command prompt;

    list disk
    select disk <disk number of USB drive>
    convert mbr
    create partition primary
    select partition 1
    format fs=fat32 quick
    Related links:
    Using WinPE builder with BurnInTest.
    Using WinPE builder with OSForensics
    Last edited by Tim (PassMark); 08-28-2018, 03:59 AM.

  • #2
    You can run WinPEBuilder with the -F option, it will show the FileSystem option. This allows the user to select the file system for the USB drive, which allows for NTFS to be used.

    See example below.

    Click image for larger version

Name:	WinPEBuilder.png
Views:	1534
Size:	31.8 KB
ID:	42790


    • #3

      I'm trying to create a bootable version of OSForensic using WinPE with this howto :
      and your post.
      However I have this error after I clicked on "Create" : Running CopyPE... copype failed with errorlevel 1.

      Click image for larger version

Name:	WinPE error.png
Views:	1641
Size:	5.1 KB
ID:	44437

      I tried to use your tips on this post but without success.
      Could you hep me please ? I don't know what I could do now !

      Thank you in advance.



      • #4
        Do you have necessary WADK for WinPE installed?


        • #5
          Yes, I already tried that.
          Here is the windows menu

          Click image for larger version

Name:	WADK.png
Views:	1620
Size:	133.7 KB
ID:	44447

          I also tried that (in french sorry) :

          But I don't have the command line "copype"...

          I really need osforensic on self-booting usb but I don't know how I could do that !



          • #6
            I assume is "Environnenment de deploiement et..." is the "Deployment and Imaging Tools" for WinPE, but we have not tested it in any Windows language version other than English. You can try to run WinPEBuilder outside of OSForensics and specify the "-k" command line option (edit the shortcut target field or via cmd) and this will keep the files used to create the WinPE around (you'll need to clean up the files later yourself). You can see the batch scripts WinPE uses to create image in the temp work directory and step through the script to see where it is failing.

            Or you can manually creating OSForensics bootable by following the PDF guide (for older version of OSForensics, but the process should be similar),


            • #7
              Thank you Richard.
              Your link refers to the command line : copype. However, I only have CopyDandI.cmd and not copype. Is it the same thing ?

              Maybe I could try to install WADK in english and not in french (and you're right "Environnenment de deploiement et..." is the "Deployment and Imaging Tools" for WinPE).
              I will try that waiting another solution (if an another solution exists ). I hope the fact I do not have copype comes from the language...


              • #8
                Not exactly sure what CopyDandI.cmd is, but from online, it seems to be for creating a WinPE image with DISM tools included. On my local installation, the WADK and WinPE scripts are located at "C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Windows Preinstallation Environment".


                • #9
                  That's good now. I didn't have "Windows Preinstallation Environment" in "C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit". I install it with this url and now it's ok.
                  Thanks for all.


                  • #10
                    apologies for reviving an older thread but i'm having an issue with this in the current build and can't get past this error.
                    Click image for larger version

Name:	osferror.PNG
Views:	1615
Size:	97.0 KB
ID:	45729


                    • #11
                      Starting with Windows 10, version 1809, WinPE is an add-on to the Windows Assessment and Deployment Kit (ADK). Previously it was included in the ADK. To get Windows PE, install the ADK, and then install the WinPE addon. Do you have Windows WinPE installed and located at the path specified?

                      See Microsoft's WinPE documentation, Where do I download it?

                      The following article provided by another user who had similar issue that corrected this error as well,


                      • #12
                        i had assumed that they put them back together as it looked like it installed all of it in one go. apparently i was mistaken, thanks that seems to have solved it.