No announcement yet.

Crash while running Directx11 Benchmark with MSI hardware [Solved]

  • Filter
  • Time
  • Show
Clear All
new posts

  • Crash while running Directx11 Benchmark with MSI hardware [Solved]

    We had a customer report an issue with PerformanceTest V9 crashing somewhere between the DX10 and the DX11 3D benchmark test.

    Crash dump analysis showed this,

    ExceptionAddress: 000000000241ba10
    ExceptionCode: c0000005 (Access violation)
    ExceptionFlags: 00000000
    NumberParameters: 2
    Parameter[0]: 0000000000000008
    Parameter[1]: 000000000241ba10
    Attempt to execute non-executable address 000000000241ba10

    SYMBOL_NAME: d3d11!D3D11CoreCreateDevice+19775
    FOLLOWUP_NAME: MachineOwner
    IMAGE_NAME: d3d11.dll
    FAILURE_BUCKET_ID: WRONG_SYMBOLS_c0000005_d3d11.dll!D3D11CoreCreateDe vice

    00000000`0014b6f8 0x241ba10
    00000000`0014b700 d3d11!D3D11CoreCreateDevice+0x19775
    00000000`0014b730 Nahimic2OSD+0x8bf9

    So the crash was in d3d11.dll in the function D3D11CoreCreateDevice.

    Hardware in use was fairly standard stuff.
    CPU: Intel Core i5-6600 @ 3.30GHz
    Motherboard: MSI H170 GAMING M3 ( MS-797 )
    Video: MSI NVIDIA GeForce GTX 1060 3GB
    Which makes the crash rather strange, as we know the software works fine on this hardware.

    Looking more closely at the stack trace above shows something strange however, that a thing call Nahimic2OSD was running at the time of the crash.

    We did some Googling and it seems Nahimic is some sound control software for MSI (we are guessing the "OSD" part of the name might mean On Screen Display?). There is also processes in Task Manager called NahimicMSISvc32, NahimicMSISvc64 & NahimicMSIUILauncher that are part of this software. (Some people might describe it as bloatware)

    It also seems the Nahimic software is really buggy. it has been reported to crash Grand Theft Auto V, BattleFront, Unravel, and many other games.

    If you uninstall it or disable it then the problems go away.

  • #2
    Update 1:
    A bit of extra information. Crash dumps from another machine showed a different process, NahimicMSIOSD, causing the problem. Presumably this is an earlier or later version of the same MSI Nahimic software, but it seems to have the same bug.

    00000000`0014d6e0 : d3d11!D3D11CoreCreateDevice+0x19775
    00000000`0014d710 : NahimicMSIOSD+0x8a99

    Update 2:
    Nahimic is developed by a french company A-Volute. It seems similar software is also included in the ASUS Sonic studio 2 software. Which also provokes crashes with various games and our software.