No announcement yet.

Problems running tests: DirectX 9, 12, GPU Compute

  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems running tests: DirectX 9, 12, GPU Compute

    So I just installed a new RTX 2080ti last night, and I wanted to see if it's running correctly. I downloaded and tried to use the testing software here, and I'm running into all kinds of problems

    When I run DirectX 9 it just shows a black screen - Strike that, just now when I ran it, it showed planes flying over a forest. It worked this time. But twice before it just showed a black screen.

    DirectX 12 shows a starfield looking thing, it moves a little bit then crashes with unexpected error running directx 12 test error number -2005270523

    And when running GPU Compute:

    The procedure entry point _glewInit@0 could not be located in the dynamic link library C:\Program Files (x86)]ASUS\GPU TweakII\GTII-OSD\x86\GTII-OSD.dll

    and after a few minutes:
    An error occured during the OpenCL Test.
    Your card may not support OpenCL or the graphics driver may be out of date.

    My driver is the latest. This really concerns me. Any help is greatly appreciated.

  • #2

    This "GTII-OSD" thing isn't our code.
    I am guessing OSD = On Screen Display. And that this ASUS GPU tweak tool is hooking into the 3D code, then doing something wrong and breaking things.

    It might be a variant of this issue

    Can you uninstall this "ASUS\GPU TweakII" thing?


    • #3
      I know this is replying to an age-old post, but I encountered a similar problem.
      Running the Passmark benchmark crashed my computer so completely the power shut off, but only when also running Asus GPU TweakII. (ROG 5700XT)
      This was only on the Direct Compute part, everything else worked fine.


      • #4
        Riva Tuner is also called Afterburner (which do similar things to TweakII) also cause problems.


        • #5
          Well this is kind of embarrassing. It turns out that specific part of the benchmark was putting a lot of stress on the GPU. And my fancy new case was pressing down on the GPU fans, preventing them from spinning. So really the system was going in thermal shutdown.

          Edit: as to why it only happened with the TweakII, the program applied a slight overclock whenever opened.