No announcement yet.

Directx 9 3D test

  • Filter
  • Time
  • Show
Clear All
new posts

  • Directx 9 3D test

    Hello I just downloaded passmark today, but i'm having problems running the benchmark it just hangs on directx9 3d test always it goes to full screen as though it start a test then back to windows screen and does nothing.. any solution?

  • #2
    First step is to check for updated device drivers.


    • #3
      Originally posted by David (PassMark) View Post
      First step is to check for updated device drivers.
      I have just updated my radeon to the latest drivers still same


      • #4
        What are the full hardware specs of the machine?


        • #5
          Originally posted by David (PassMark) View Post
          What are the full hardware specs of the machine?
          AMD 8350 @ 4.8ghz OC H80i water cooler
          Asus sabertooth 900fx
          8gb 1600 corsair memory
          HD7870 3GB Sapphire graphics
          256GB samsung 840 SSD
          antec neo 550watt PSU
          fracal design define R4 case


          • #6
            The DirectX9 test has been stable for several years (and working on over 500,000 machines), so we need to be looking for what is special about your machine.

            Can you try it again without overclocking.

            Do you using dual / tri monitors?

            Are you running on the default settings in the device driver?

            Are you using any 3rd party software that might interfere with the video performance (e.g. remote desktop, fraps, etc..)


            • #7
              I get the same result, but on different system hardware. Of note I am running windows 8.1, which if I had to shoot from the hip I would say may be the issue. My hardware is an i7-4820, gtx 770, 32G 1600 ram, 850W psu, define R4 case, asrock extreme6 motherboard, a single asus monitor running at 2560x1440 via dual link dvi.

              It's a brand new system with the latest non-beta nvidia drivers, all default settings. DirectX 9 based games work fine in windows and full screen ( Even at lower resolutions like 1024x768 ).

              When running passmark, everything proceeds well until the Direct3d 9 complex test starts. The screen goes black, the monitor's resolution switches down low, a see a giant fat mouse cursor, then I drop back to the desktop and the performance test will just sit there forever and never complete. Of note there is another window associated with the process that just shows up as solid white in the mouse-over preview. I assume this is the full screen app that the performance test tried to launch.

              Well guess what... if I set Performance Test to run in Windows 8 Compatibility mode (new in Windows 8.1 I guess) the DirectX 9 complex test runs just fine. In fact the whole series of tests run to completion. The problem is, in this mode there seemed to be a slowdown on the tests. The 2D test took a hard, hard hit. Don't get me wrong it was still relative fast, but the 2D test was half of what it was before running in win 8 compatibility mode. This all strongly suggests there is some wonderful little issue MS created in win 8.1 that may require investigation...
              Last edited by virgilw; 11-17-2013, 01:36 AM. Reason: Additional Info


              • #8
                Could you please try running PerformanceTest in debug mode (described here) and send us a copy of the debug log after you reproduce the crash (our email details).


                • #9
                  I have some info... and it changes things significantly.
                  Since this is brand new hardware, I installed win 7 on a separate drive. Good idea I figured to see how it would compare.

                  I did as little as possible after installing win 7, ran performance test, and guess what. Hang with the complex directx9 test. Stupified, I tried the other tests (dx10, 11) one at a time and they were fine.

                  After much messing around, I have made the test work properly by installing the latest intel chipset (inf) drivers. Do this under win 8.1 and the problem resolves there as well. After installing the latest chipset drivers the 2d tests slow down significantly, but all tests run to completion.

                  No idea why, I just know that this can't be win8.1 related anymore since I reproduced it with win 7. And the fix was chipset drivers. Games and other things were working fine prior to the latest chipset drivers being installed, so who knows. No idea why the 2d tests takes such a pounding either. Perhaps a similar solution would help the original poster of this thread, though.

                  In any case there probably isn't anything for PassMark to look at (at least in my scenario).


                  • #10
                    Thanks for the follow up.

                    We had also tested Win8.1 in house, but didn't see any problems, but we would have had all the drivers installed when we did our testing.