Announcement

Collapse
No announcement yet.

GPU Compute runs to no result

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • GPU Compute runs to no result

    Runs performance test 11.0 trial version. Each time when I try to run the GPU compute test, it opens a graphic window and some test seems running. Then it closed, the software shows 0% progress, then go back to the previous screen. No error, no results show up. Can anyone help to figure this out? It seems like the GPU compute does not run properly.
    My PC: Nvidia GTX 1650 4GB, Intel Xeon E3-1230 v6 CPU, Supermicro X11SSL-F motherboard. 16GB ram.
    Thanks!

  • #2
    Very likely you haven't got the latest video card device drivers for the video card.

    Also check you are using the latest patch release of PerformanceTest.

    If you are, and still have a problem, can you post a debug log
    https://www.passmark.com/support/per.../debug-log.php

    Comment


    • #3
      Yes I have checked I am running the latest nvidia driver and newest version of the performancetest11. Same problem. Here are the debug log attached.
      PerfTestLog.txt
      Code:
      0.000s - DEBUG: Starting...
      0.000s - DEBUG: Start time: 2023/06/07, 21:48:03.108
      0.000s - DEBUG: PerformanceTest 11.0 build 1002 64-Bit
      0.000s - DEBUG OS: Windows 10 Professional Edition build 19045 (64-bit)
      0.000s - DEBUG Path: C:\Program Files\PerformanceTest
      0.000s - DEBUG Command line: "C:\Program Files\PerformanceTest\PerformanceTest64.exe" DEBUGMODE
      0.000s - Date: 06/07/23 21:48:03
      0.000s - GetPersonalFolder: C:\Users\yg\Documents
      0.000s - DEBUG GetPersonalFolder C:\Users\yg\Documents\PassMark\PerformanceTest11
      0.000s - Selected drive C
      0.000s - HORZRES - 1920 VERTRES - 1080
      0.015s - LOGPIXELSY - 96 LOGPIXELSX - 96 DPIScale - 1.000000
      0.015s - TEMP DEBUG csum ok: 1
      0.015s - DEBUG: Opening splash window
      0.047s - GetCommonApplicationDataFolder: C:\ProgramData
      0.094s - Looking up CPU specification for "Baseline #3": AMD Ryzen 9 3900 12-Core Processor 23 113 0
      0.094s - CPU specification not found
      0.156s - Looking up CPU specification for "Baseline #5": 12th Gen Intel(R) Core(TM) i7-12700H 6 154 0
      0.172s - Looking up CPU specification for "Baseline #6": AMD Ryzen 5 Microsoft Surface (R) Edition 23 96 0
      0.172s - CPU specification not found
      0.172s - Looking up CPU specification for "Baseline #7": AMD Ryzen Threadripper 1950X 16-Core Processor 23 1 0
      0.172s - CPU specification not found
      0.203s - DEBUG: Retrieving Computer Name
      0.203s - DEBUG: Retrieving OS Name
      0.281s - Windows 10 Professional Edition build 19045 (64-bit)
      0.281s - DEBUG: Retrieving Graphics Info
      1.390s - DEBUG: SysInfoDll_GetGraphicsInfo OK
      1.390s - Video adapters: check unsupported
      1.390s - Video adapters: iNumDD 1
      1.390s - Video adapter 0: bDisplay: 1 szDeviceDescription: NVIDIA GeForce GTX 1650 szDriverVersion: 535.98 : Memory: 4294639616
      1.390s - Monitor 0:1 1920x1080x32 60Hz 96 DPI (Primary monitor)
      1.390s - DEBUG: Retrieving USB Info
      1.625s - DEBUG: GetProcessList
      1.625s - DEBUG: SysInfoDLL_Results::GetProcessList start
      1.625s - DEBUG: SysInfoDLL_Results::GetProcessList finished
      1.625s - DEBUG: Get apps
      1.719s - DEBUG: finished quickgather
      1.719s - DEBUG: Checking language and local
      1.719s - DEBUG: Got language and local
      1.719s - DEBUG: Creating main window
      1.781s - DEBUG: Updating Baseline List
      1.781s - Updating baseline: using OS:
      1.781s - Windows 10 Professional Edition build 19045 (64-bit)
      1.828s - DEBUG: Finished updating Baseline List
      1.828s - Got WM_EXITSIZEMOVE message
      1.890s - CD3DApplication::BuildDeviceList start
      1.890s - CD3DApplication::BuildDeviceList adapter 0 of 1  
      1.890s - CD3DApplication::BuildDeviceList finish
      1.890s - DEBUG PERF: Initialize3DEnvironment
      4.500s - g_D3D9ComplexDeviceUsed found (NVIDIA GeForce GTX 1650)
      4.500s - Got WM_EXITSIZEMOVE message
      4.500s - WM_EXITSIZEMOVE: BackBufferWidth 690 : BackBufferHeight 434 (previous: 491 : 625)
      4.515s - Got WM_EXITSIZEMOVE message
      4.515s - WM_EXITSIZEMOVE: BackBufferWidth 774 : BackBufferHeight 619 (previous: 690 : 434)
      4.531s - GetPersonalFolder: C:\Users\yg\Documents
      4.531s - DEBUG GetPersonalFolder C:\Users\yg\Documents\PassMark\PerformanceTest11
      4.531s - GetPersonalFolder: C:\Users\yg\Documents
      4.531s - DEBUG GetPersonalFolder C:\Users\yg\Documents\PassMark\PerformanceTest11
      4.531s - GetPersonalFolder: C:\Users\yg\Documents
      4.531s - DEBUG GetPersonalFolder C:\Users\yg\Documents\PassMark\PerformanceTest11
      4.531s - GetPersonalFolder: C:\Users\yg\Documents
      4.531s - DEBUG GetPersonalFolder C:\Users\yg\Documents\PassMark\PerformanceTest11
      4.531s - GetPersonalFolder: C:\Users\yg\Documents
      4.531s - DEBUG GetPersonalFolder C:\Users\yg\Documents\PassMark\PerformanceTest11
      4.531s - GetPersonalFolder: C:\Users\yg\Documents
      4.531s - DEBUG GetPersonalFolder C:\Users\yg\Documents\PassMark\PerformanceTest11
      4.531s - GetPersonalFolder: C:\Users\yg\Documents
      4.531s - DEBUG GetPersonalFolder C:\Users\yg\Documents\PassMark\PerformanceTest11
      4.531s - GetPersonalFolder: C:\Users\yg\Documents
      4.531s - DEBUG GetPersonalFolder C:\Users\yg\Documents\PassMark\PerformanceTest11
      4.531s - GetPersonalFolder: C:\Users\yg\Documents
      4.531s - DEBUG GetPersonalFolder C:\Users\yg\Documents\PassMark\PerformanceTest11
      4.531s - GetPersonalFolder: C:\Users\yg\Documents
      4.531s - DEBUG GetPersonalFolder C:\Users\yg\Documents\PassMark\PerformanceTest11
      4.531s - DEBUG: Creating performance stats thread
      4.531s - DEBUG PERF: CPerformanceStats::Init start
      4.719s - DEBUG PERF: CPerformanceStats adding counter
      4.719s - DEBUG PERF: Added counter
      4.719s - DEBUG PERF: CPerformanceStats::Init end
      4.719s - DEBUG: Performance stats initialised
      4.719s - DEBUG: Initialising bitmap resources
      4.734s - DEBUG: Closing splash window
      4.734s - DEBUG: RP 1
      4.734s - DEBUG: RP 2
      4.734s - DEBUG: RP 3
      4.734s - DEBUG: RP 4
      4.734s - DEBUG: RP 5
      4.734s - DEBUG: RP 6
      5.031s - DEBUG: RP 7
      5.031s - DEBUG: RP 9
      5.031s - DEBUG: RP 11
      5.031s - DEBUG: RP 12
      6.844s - DEBUG: RP 14
      6.844s - DEBUG: RP 15
      6.844s - DEBUG: RP 18
      6.844s - DEBUG: Finished Welcome Window
      7.000s - DEBUG: Launch System Information Thread
      7.000s - DEBUG: Check for battery power
      7.000s - DEBUG: Check for power saver plan
      7.000s - DEBUG: Check for effective power mode
      7.000s - DEBUG: Check for script
      7.000s - DEBUG: Entering message loop
      7.109s - SysInfoThread start
      7.109s - DEBUG: SlowGather
      7.109s - DEBUG: Retrieving Disk Info
      10.515s - DEBUG: Retrieving SMART Info
      17.734s - DEBUG: Retrieving Memory Info
      17.734s - DEBUG: Retrieving CPU Info
      26.344s - AMD integrated graphics check
      26.344s - [DD 0] 0x1F82
      26.344s - DEBUG: Retrieving Memory SPD Info
      30.390s - DEBUG: Retrieving WMI Info
      39.187s - DEBUG: Retrieving SMBIOS Info
      47.109s - DEBUG: SysInfoDLL failed to get SMBIOS Info
      47.625s - DEBUG: Disk Info
      47.625s - Hard Drive: Samsung SSD 860 QVO 1TB (1TB) SATA
      
      47.625s - DEBUG PERF: PHYSDISKINFO is NULL for index 1
      47.625s - Hard Drive: TrueNAS iSCSI Disk SCSI Disk Device (2TB) ISCSI
      
      47.625s - DEBUG: SlowGather - Get temperatures
      49.953s - DEBUG: SlowGather - finished
      49.953s - SysInfoThread GetCleanModelName CPU (Intel(R) Xeon(R) CPU E3-1230 v6 @ 3.50GHzd)
      49.953s - GetCleanModelName GetModelListFromCache
      49.953s - GetCommonApplicationDataFolder: C:\ProgramData
      49.984s - GetCleanModelName find clean name
      49.984s - GetCleanModelName Intel Xeon E3-1230 v6 @ 3.50GHz
      49.984s - GetCleanModelName sort model list
      49.984s - GetCleanModelName clean up list
      49.984s - GetCleanModelName finished 1 (using Intel Xeon E3-1230 v6 @ 3.50GHz)
      49.984s - SysInfoThread GetCleanModelName G2D (NVIDIA GeForce GTX 1650)
      49.984s - SysInfoThread NVIDIA GeForce GTX 1650
      49.984s - GetCleanModelName GetModelListFromCache
      49.984s - GetCommonApplicationDataFolder: C:\ProgramData
      50.000s - GetCleanModelName find clean name
      50.000s - GetCleanModelName GeForce GTX 1650
      50.000s - GetCleanModelName sort model list
      50.000s - GetCleanModelName clean up list
      50.000s - GetCleanModelName finished 1 (using GeForce GTX 1650)
      50.000s - SysInfoThread GetCleanModelName Mem
      50.000s - SysInfoThread SPD JEDEC manuf: Kingston
      50.000s - SysInfoThread SPD P/N: 9965669-031.A00G    
      50.000s - GetCleanModelName GetModelListFromCache
      50.000s - GetCommonApplicationDataFolder: C:\ProgramData
      50.031s - GetCleanModelName find clean name
      50.031s - GetCleanModelName Kingston 9965669-031.A00G 16GB
      50.031s - GetCleanModelName sort model list
      50.047s - GetCleanModelName clean up list
      50.047s - GetCleanModelName finished 1 (using Kingston 9965669-031.A00G 16GB)
      50.047s - SysInfoThread GetCleanModelName HDD
      50.047s - GetCommonApplicationDataFolder: C:\ProgramData
      50.078s - SysInfoThread GetCleanModelName HDD g_cleanHDDModelList numItems: 3
      50.078s - Samsung SSD 860 QVO 1TB
      50.078s -
      50.078s -
      50.078s - SysInfoThread GetCleanModelName HDD SMARTDeviceInfo
      50.078s - Samsung SSD 860 QVO 1TB
      50.078s - SysInfoThread GetCleanModelName HDD g_szCleanHDDModel Samsung SSD 860 QVO 1TB iDiskIndex 0
      50.078s - Samsung SSD 860 QVO 1TB
      50.094s - SysInfoThread GetCleanModelName HDD OK
      50.094s - SysInfoThread Redraw
      50.094s - SysInfoThread finished
      50.094s - DEBUG: Updating Baseline List
      50.094s - Updating baseline: using OS:
      50.094s - Windows 10 Professional Edition build 19045 (64-bit)
      50.140s - DEBUG: Finished updating Baseline List
      51.828s - Updating baseline: using OS:
      51.828s - Windows 10 Professional Edition build 19045 (64-bit)
      51.844s - DEBUG: GetTemperature
      56.828s - Updating baseline: using OS:
      56.828s - Windows 10 Professional Edition build 19045 (64-bit)
      56.844s - DEBUG: GetTemperature
      61.828s - Updating baseline: using OS:
      61.828s - Windows 10 Professional Edition build 19045 (64-bit)
      61.844s - DEBUG: GetTemperature
      66.828s - Updating baseline: using OS:
      66.828s - Windows 10 Professional Edition build 19045 (64-bit)
      66.844s - DEBUG: GetTemperature
      71.656s - GetCommonApplicationDataFolder: C:\ProgramData
      71.656s - GetChartDataFromCache - C:\ProgramData\PassMark\PerformanceTest11\Chart Data\g3dRating\all.xml
      73.328s - DEBUG: Running Test - GPU Compute
      73.328s - Start DirectCompute test
      73.328s - RunMandelbrotTest
      91.140s - RunNBodyTest
      91.140s - GetCombinedAdapterList start
      91.140s - GetCombinedAdapterList Getting DirectX Adapters
      91.140s - GetCombinedAdapterList enum DX adapters
      91.140s - DX Adapter Found: NVIDIA GeForce GTX 1650
      91.140s - DX Adapter Found: Microsoft Basic Render Driver
      91.140s - DX Adapter Found: Microsoft Basic Render Driver
      91.156s - GetCombinedAdapterList Getting OpenCL Adapters
      91.219s - > Found 4 OpenCL Platforms(s)
      91.219s - Platform: NVIDIA Corporation NVIDIA CUDA [OpenCL 3.0 CUDA 12.2.68]
      91.219s - > Found 1 device(s) on platform.
      91.219s - > GPU 0: NVIDIA GeForce GTX 1650 [NVIDIA GeForce GTX 1650]
      91.219s - >   Driver Ver: 535.98
      91.219s - >   Compute Units: 14
      91.219s - >   Clock Freq: 0 MHz
      91.219s - >   Image Specs: 0 x 0
      91.219s - Platform: Intel(R) Corporation Intel(R) OpenCL [OpenCL 3.0 WINDOWS]
      91.219s - ERROR: clGetDeviceIDs failed [-1] (1).
      91.219s - Platform: Intel(R) Corporation Intel(R) FPGA Emulation Platform for OpenCL(TM) [OpenCL 1.2 Intel(R) FPGA SDK for OpenCL(TM), Version 20.3]
      91.219s - ERROR: clGetDeviceIDs failed [-1] (1).
      91.219s - Platform: Intel(R) Corporation Intel(R) FPGA SDK for OpenCL(TM) [OpenCL 1.0 Intel(R) FPGA SDK for OpenCL(TM), Version 2022.1]
      91.219s - ERROR: clGetDeviceIDs failed [-1] (1).
      91.219s - OnRunNbodyTest - Enter loop: CurAdapter 0 [NVIDIA GeForce GTX 1650]
      91.234s - OnRunNbody - end
      0.937s - NbodyGravity start setup
      0.937s - NbodyGravity call InitApp
      0.937s - NbodyGravity call DXUTInit
      0.953s - NbodyGravity call DXUTCreateDevice
      2.734s - Workgroup Dims = (256 x 1)
      94.078s - NBodyTest - collate results
      94.078s - NBodyTest - close handles
      94.078s - DEBUG PERF: calc_mark_vals CPU test 1 result is 0
      94.078s - GetCommonApplicationDataFolder: C:\ProgramData
      94.078s - DEBUG PERF: calc mark num3DTestRun = 0
      94.078s - DEBUG PERF: calc mark everything
      94.078s - DEBUG PERF: numtest < 5
      94.078s - DEBUG PERF: num3DTestRun 0
      94.375s - TEMP DEBUG csum 2 ok: 1
      94.375s - TEMP DEBUG csum 3 ok: 1
      94.375s - GetCommonApplicationDataFolder: C:\ProgramData
      94.375s - GetChartDataFromCache - C:\ProgramData\PassMark\PerformanceTest11\Chart Data\g3dRating\all.xml
      94.422s - GetCommonApplicationDataFolder: C:\ProgramData
      94.422s - GetChartDataFromCache - C:\ProgramData\PassMark\PerformanceTest11\Chart Data\G3D_DIRECTCOMPUTE\all.xml
      94.453s - GetCommonApplicationDataFolder: C:\ProgramData
      94.453s - GetChartDataFromCache - C:\ProgramData\PassMark\PerformanceTest11\Chart Data\g3dRating\all.xml
      94.500s - GetCommonApplicationDataFolder: C:\ProgramData
      94.500s - GetChartDataFromCache - C:\ProgramData\PassMark\PerformanceTest11\Chart Data\G3D_DIRECTCOMPUTE\all.xml
      96.750s - GetApplicationDataFolder: C:\Users\yg\AppData\Local
      96.750s - Saved config - Selected drive C
      96.750s - GetPersonalFolder: C:\Users\yg\Documents
      96.750s - DEBUG GetPersonalFolder C:\Users\yg\Documents\PassMark\PerformanceTest11
      96.750s - DEBUG PERF: End perf startup
      96.828s - DEBUG: Leaving message loop
      
      ​

      Comment


      • #4
        SysInfoLog attached
        Attached Files

        Comment


        • #5
          Seems to have failed during the initialization of OpenCL. Maybe crashed (hardware failure?), or maybe some unusual setup.

          We are also going to add a new more debugging log lines to narrow it down some more.

          Same test has run on 12,000+ machines with the 1650 video card, so there must be something special about your setup.

          Also, can you try disabling your Intel graphics?

          Comment


          • #6
            Can you try running the below build with extra debug lines in debug mode and send us the logs:
            https://www.passmark.com/downloads/t...g_20230609.exe

            Comment


            • #7
              I believe the other graphics ability of my computer is from the IPMI chip on the motherboard. I doubt I can disable it nor I want to disable it.
              I am running the extra debug version you send. Will get back to you.

              Comment


              • #8
                Here is the new debug log files. Attached.
                Attached Files

                Comment


                • #9
                  Figured I'd sign up to say that a common cause of this error seems to be just having Intel CPU Runtimes for OpenCL™ Applications installed.

                  If you have that or any other OpenCL runtime package installed, try removing it and running passmark again.

                  It seems the GPU compute test was not designed around the possibility of someone having CPU support for OpenCL.

                  Comment


                  • #10
                    It is true that in the log above there are 4 different OpenCL instances on the system.
                    NVIDIA Corporation NVIDIA CUDA [OpenCL 3.0 CUDA 12.2.68]
                    Intel(R) Corporation Intel(R) OpenCL [OpenCL 3.0 WINDOWS]
                    ​Intel(R) Corporation Intel(R) FPGA Emulation Platform for OpenCL(TM) [OpenCL 1.2 Intel(R) FPGA SDK for OpenCL(TM), Version 20.3]
                    Intel(R) Corporation Intel(R) FPGA SDK for OpenCL(TM) [OpenCL 1.0 Intel(R) FPGA SDK for OpenCL(TM), Version 2022.1]

                    But it does seem to launch the test on the Nvidia instance however.
                    We'll see if anything can be reproduced.

                    Comment


                    • #11
                      Just an FYI, I have the same problem. New Asus G18 G834JY with Nvidia 4090. All windows 11 updates and updated drivers. Gets thru all test except the GPU Compute test. On this, it seems to complete the first segment of it, but as soon as it tried to load the next part it gives a 0 score and back to main test/results screen.

                      Comment


                      • #12
                        Turbo12R
                        Can you post a debug log for us to have a look:
                        https://www.passmark.com/support/per.../debug-log.php

                        Comment


                        • #13
                          Well, oddly enough as soon as I put that in the command line it made it all the way through the test.

                          Comment


                          • #14
                            ASUS S501ME (Intel Core™ i7-13700, NVIDIA GeForce RTX™4060TI DUAL 8GB GDDR6,Intel B760 Chipset​).

                            The tests run without error, however, the GPU compute mark is unavailable.
                            I will attach more details later.

                            Click image for larger version

Name:	屏幕截图 2023-11-04 204736.png
Views:	147
Size:	135.8 KB
ID:	56191

                            Comment


                            • #15
                              Can you post a debug log for us to have a look:
                              https://www.passmark.com/support/per.../debug-log.php

                              Comment

                              Working...
                              X