No announcement yet.

TestLog Web Access: "Page cannot be displayed" if test case is multiple folders deep.

  • Filter
  • Time
  • Show
Clear All
new posts

  • TestLog Web Access: "Page cannot be displayed" if test case is multiple folders deep.

    Hey Guys,

    We have been using TestLog for quite some time now and it has been working great. The testing of our products is extremely complex and pretty much requires various multiple sub folders in the projects - and up to now, this has never been a problem. However, we recently opened an office in India that we're trying to bring online now and they are having problems displaying the "deeper" test cases when using the Web interface. To replicate the bug, do the following.

    1. I create a project titled "India access test"
    2. Create a new test suite titled "Test Suite level 1" and put a simple generic test case in it.
    2. Within that test suite, create a new test suite called "Test Suite level 2" and put a generic test case in it.
    3. Within that test suite, create a new test suite called "Test Suite level 3" and put a test case in it.

    Do this until you are at least 3 or 4 test suites deep in the project folder. Now, close TestLog and open the TestLog web interface. Browse to this test case and you will find that after you are a couple of folders deep in the test suites, you will start getting "Page cannot be displayed". Sometimes, you can click on the test case and it will display but if you click the "edit" link, you will again see the page cannot be displayed message.

    This is a bit of a problem for us because I have months of organization in our test procedures that would take a huge amount of effort to reorganize into a structure that is not multi-level - if it could even be organized that way in a usable manner for us. The multiple levels of test cases are needed because of the complexity and depth of the testing procedures for our products. Could you please look into fixing this for us? Currently our India test team is not able to access our database remotely so we're having to mirror it then merge it all manually. Needless to say, I need this resolved ASAP.

    Please let me know if you have seen this or know what the problem may be. We are currently using TestLog build 1016 and all systems used to access TestLog through the web are running Windows XP 32bit and the latest version of Internet Explorer.

    Thank you!

    By the way. I just wanted to comment on our ability to keep one database in Texas and have our India users edit it from India via the web interface. At the moment, this all seems to work very fast and is very usable. I think it's great that you supply a product that is so easy to setup and use in this manner with little or no latency half-way around the world! Nice work!

  • #2
    Thanks for reporting this, we'll look into what could be causing it. Are you using Apache or IIS and what OS is the web server running?


    • #3

      The system that we are serving TestLog from is running Windows 2003 server. At this location, we just run the TestLog application on our local machines to edit the database so up to now, we have only used the web access for others to view the progress reporting features. We would prefer our India users to edit via the web access though. All systems (both server and machines being used to login to TestLog) are using Internet Explorer version 7.0.5730.11 and have the latest hot fixes from Microsoft.

      I'll try hosting this on a completely different machine and see if the results are the same - just to try and rule out any other potential software issues.

      Sorry...I forgot to mention...we're using Apache on the server.

      Thank you!
      Last edited by TL-user1; Nov-13-2007, 04:16 PM.


      • #4
        Thanks for the extra info, so far i haven't been able to replicate it at all. Could you post one of the URLs that isn't displaying correctly along with the database path from the : DATABASES_START: section of you config file.

        Also be aware that Windows path limitation of 260 characters still applies to the web version like it does to the standalone version of TestLog.
        Last edited by Tim (PassMark); Nov-15-2007, 02:15 AM.


        • #5
          Well, we tried setting this up using another web server (non-Apache) so that we could compare results and after more than a day of trying to get it going, nothing would connect to it through TestLog. I'm not yet sure if this is yet another incompatibility but at this point, I simply have no more time to spend diagnosing these issues. We currently have our India users trying to use the installed TestLog build instead of the web interface but for us, this is not an acceptible long term solution. Reason being, when using it in this manner, we're now having problems with random "locked" files, the application freezing on some systems, etc. and this was not happening before. Also, we have to mirror the database to use it like this because it takes way to long for the installed TestLog app to load the complete database remotely. I'm guessing at this point that it's because the software is simply not designed to be used in this manner which is completely understandable.

          I appreciate your help with this but since you cannot replicate the web issue to fix it, I fear that by Q2 of next year, we will have to migrate to a product that better suits our needs. Thank you again for your help.


          • #6
            we had a similar problem, and it turned out to be a limitation in the windows path length. Where is your testlog web-app loaded on the server? and where are the databases stored on the server? if your databases are buried somewhere in the file system (i.e. c:\documents and settings\current user\desktop\etc\etc.) the path may be too long. Also, you may want to try shortening the test suite/project names... instead of making them long like 'test suite level 2', make them 'suite l2', and maybe change 'india access test' to just 'india', and see if that helps. Also, if your database name is long, that could be another reason it's breaking (our DB's are named '6.0.1_db' or similar).

            for our server we moved all the web stuff to c:\testlog\ and that fixed a lot of the 'page cannot be displayed' problems we saw, as well as shortening the test suite names to all be around/under 10 characters.


            • #7
              Yeah, I thought it was the windows naming limitation too as we've hit that problem with TestLog before but unfortunately that does not seem to be the case now. The TestLog database is in the root of the D: drive on our server and is named the default "TestLog". This was done in an effort to keep the path names to a minimum but it didn't help. I've also tried shortening the folder names to "A", "B", etc...but it did not change the remote access problem. I just can't get anything more than 3 or 4 folders deep to display properly in the web interface.....still not sure why. Thanks for the suggestions though! -Tony