Announcement

Collapse
No announcement yet.

Unable to open cgiconfig.cfg file or file did not follow the expected format

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to open cgiconfig.cfg file or file did not follow the expected format

    I get the following error, while trying to access through web.
    I did follow the remote install guide.

    Unable to open cgiconfig.cfg file or file did not follow the expected format. Please see the help guide for more information on setting up TestLogCGI.

    Configuration:
    - Apache 2.2
    - TestLog v3.0 1004

    cgiconfig.cfg file looks like this
    #TestLogCgi config file
    #The location of the TestLog directory for images, relative to the base URL of your web server
    :IMAGESREL:/TestLog/images/

    #The location of the TestLog directory for images, absolute path (same location as above but absolute)
    :IMAGESABS:C:\apps\apache22\htdocs\TestLog\images\

    #The location of the TestLog directory for help, relative to the base URL of your web server
    :HELPREL:/TestLog/Help/

    #Temp folder location, used for sesssion files etc
    :TEMPDIRABS:C:\temp\Testlogcgi

    #Session timeout value in minutes
    :TIMEOUT:60

    #The location of the Templates directory, absolute path
    :TEMPLATEABS:C:\apps\apache22\htdocs\TestLog\templ ates\
    #there is no space in that word "templates", this bulletin board software is putting that space

    #The paths to the databases, absolute paths
    ATABASES_START:
    C:\temp\SampleDB
    ATABASES_END:

    #Key Section - Purchased licence keys
    :KEYSECTION_START:
    45B5A2C4010967B6A785306EA1990B1F649C800D92
    :KEYSECTION_END:

    #EBUGMODE:
    Any help is greatly appreciated.

    Thanks

  • #2
    The only obvious thing is the :TEMPLATEABS: tag doesn't need the trailing "templates" part of the path name, "C:\apps\apache22\htdocs\TestLog\" is sufficient, however this would prompt a different error message.

    Does the user Apache is running under have the correct permission to access the config file?

    It seems if there is a blank line after the last tag it can throw this error, can you make sure the DEBUGMODE line is the last line in the file.

    The next version has been changed to make a distinction in the error message between being unable to access the file and if there is an actual problem with the file structure, as well as not throwing an error if the last line of the file is an empty line.
    Last edited by Tim (PassMark); 04-15-2007, 11:37 PM. Reason: Possible empty line problem and next version changes

    Comment


    • #3
      Tim,

      Thanks for reply

      1. cgiconfig.cfg has full permission to everyone, and the adminstrator (the user apache is running) has full permission to this file.

      2. Yes DEBUGMODE line is the last line, there is no space or newline after it.

      3. I have tried this on various machines, WIN XP PRO, WIN VISTA ultimate x64, WIN 2003 Server, but the same error, has anyone got this working on apache?

      4. So when is the next version coming out?


      Thanks again for replying.

      Comment


      • #4
        New build should be ready early tomorrow.

        Comment


        • #5
          Tim,
          Thanks for the info, I downloaded the alpha version for build 1005 from here http://www.passmark.com/ftp/testlog3.0.1005-a.exe,

          It is that same red error.

          I followed all your suggestions and tried other combination too.

          No Luck.

          Thanks

          Comment

          Working...
          X