No announcement yet.

Not enough free disk space on Floppy

  • Filter
  • Time
  • Show
Clear All
new posts

  • Not enough free disk space on Floppy

    I have BIT v3.0 installed on a computer running WinXP Pro. I initially had several problems and after reading some previous posts, I downloaded BIT v4.0 to try. It seems to have solved some issues but one remains: The floppy drive reports "Not enough free disk space" when I run the test. I've tried several different disks but the problem persists, in v3.0 and v4.0. Any ideas?

  • #2
    A floppy disk uses the old FAT file system. The FAT file system has been replaced on hard disks by FAT32 and more recently with NTFS (in Windows NT, 2000 & XP). Floppy disks still use FAT on all systems howevers for compatibility reasons.

    In the FAT file system there are a limited number of files that can be created in the root directory of a floppy disk. The number of files that can be created depends on the length of each file name. (and does NOT depend on free disk space).

    So if you have setup BurnInTest to create large number of small test files you might see a disk full error on a floppy before the disk is actually full.

    This can be avoided by increasing the "File size" value in the disk preferences tab in BurnInTest. This will result in fewer files of larger size being created.



    • #3
      Drive Not Ready

      I receive this message in a pop up window: "The drive is not ready for use; its door may be open. Please check drive A: and make sure that a disk is inserted and that the door is closed." Choices are cancel, try again, or continue.

      I'm using BIT 4 (registered) on WinXP. I get this error only when I am running multiple tests at one time. I also get errors reported on the serial and parallel ports. If I remove drive A: from the drive list and run the same tests, all is ok, no errors on serial or parallel ports. Is this somehow caused by the FAT filesystem problem?


      • #4
        No this error is not related to the FAT file system nor is it related to the amount of free space on the disk.

        There are several possibilities,

        1/ The floppy disk media (or the drive itself) is bad and this causes the "not ready for use" error. The time taken in attempting to access the bad floppy disk could then result in timeout errors on the serial and parallel ports. So try a new blank disk.

        2/ There is an old BIOS bug in some PCs that caused similar behaviour when the floppy was used at the same time as the serial port. So check to see if new BIOS is available for your motherboard.

        3/ You don't have a floppy disk in the drive and the error is valid. You need a disk in the drive for the test to work. (I know this might sound stupid but we see a lot of silly stuff here)

        If you post a sample of the error messages from the BurnInTest log file we might be able to provide more details.



        • #5
          1. Yes I have a disk in the drive.
          2. I've tried several new floppy disks.
          3. This is on a new computer, BIOS is current. (Motherboard is Intel Desktop Board D845GERG2)
          3. I've had this message pop up on several different computers I've run BIT on.
          4. This problem happens after BIT has been running for some time, sometimes 15 minutes, sometimes 2 hours later.

          Sample from the error log:
          2004-07-20 10:29:19, Serial, SERIOUS: The requested COM port could not be found
          2004-07-20 10:29:19, Serial, \\.\COM1 Handle:FFFFFFFF Total: 345600, ErrorCode: 0
          2004-07-20 10:29:20, Disk, WARNING: A: Test file could not be re-opened
          2004-07-20 10:29:20, Disk, File that count not be opened: A:\~bittestA00520
          2004-07-20 10:29:20, Parallel, Sent: 1, Rec: 15, Att: 1, RawByte: 255, Loop:0
          2004-07-20 10:29:20, Parallel, SERIOUS: Corruption. Data received didn't match data sent

          These 3 errors keep repeating until the max log file size is reached.

          I'm going to assume that if the floppy drive can pass the test individually, the drive is fine. The "old" BIOS bug is only evident when multiple tests are running, but does not necessarily mean the drive is bad.


          • #6
            The errors you have included above are not timeout errors.

            They do look more like the errors we saw with the 'old' BIOS problem.

            Around Sept 2002 we investigated a problem like this with National Semiconductors, (the people who make the Super I/O chips, which control the COM ports and floppy drives, on many motherboards). They had similar problems with COM ports but only when running other I/O activities at the same time, in particular the floppy disk.

            After *many weeks* of investigation they found a problem in their BIOS/CMOS layout that caused the COM port to be disabled from time to time. We also had an Asia manufacturer with a similar issue before that (who didn't want to be indentified as they didn't want to fix the problem).

            National Semiconductors went on to correct the problem in early 2003 (as far as I know).

            I think the 845 board came out during this time period but the board you mentioned uses the SMSC LPC47M172 Super I/O chip. This chip seems to be compatible of the National Semiconductor PC87372 chip however and the PC87372 is used on many 845 boards.

            Anyway, we believe the problem is in your machine, but we don't have any solution if you have already upgraded the BIOS.

            Are you a home user or a larger manufacturer? For example, are you in a position to pressure your supplier to investigate the issue at a detailed technical level?



            • #7
              Since there is no fix available, I would like to see some more detail on this bug. Do you have, or where can I find, information on this BIOS bug? During searches, I've seen references to a NEC765A bug. Is that it?


              • #8
                I believe that the problem is in your machine. As such I can't say if a fix is available or not.

                Using the floppy disk and serial ports at the same time is a rare event. It might not be worth investigating the problem. i.e. It might be cheaper to live with the issue. If you are mass producing 1000's of machines in this configuration, it might be a more significant issue however.

                Yes there is a very very old issue from the early 1980s regarding NEC. NEC & Intel made a floppy disk drive controller chip but it had a bug. NEC was slow in fixing the bug, and in between time Toshiba reversed engineered the chip and copied the bug. Toshiba then went on to sell the buggy chip for several years durng the late 1980s. There was a claim that they sold the buggy chip for up to 10 years, even though they knew about the bug.

                The bug caused files on floppy disk to become corrupted when the bus was under heavy load.

                Toshiba was later sued in a class action for $2.1 billion and gave compensaion to all customers who bought a laptop after Jan 1, 1985. Similar suits were filed against Compaq, eMachines, Hewlett-Packard, and Packard Bell NEC.

                All this is really *old* news however, and as far as I know this bug never had anything to do with serial ports. So I don't think this is your particular problem.

                Some things you could try however would be to,
                1/ Try a different make of floppy drive
                2/ Try moving the serial port I/O addresses to a new location (away from the default 03F8 address)

                I don't have any other additional information about the bug. But if you find a solution please post it here.