No announcement yet.

BITpro testing in Win PE 2.x

  • Filter
  • Time
  • Show
Clear All
new posts

  • BITpro testing in Win PE 2.x

    I am creating a new thread for this because my initial issue was solved. This thread is designed for us to post ideas, methods and results of getting BurnInTest Pro to work in Windows PE 2.x. I am aware that PassMark is working on supporting this environment, but this may at least help in some respect. I am also working on a guide for creating the media, but I will not post it until I have worked out all the bugs.

    Here are some things that you need to test within the scope of this project:
    - Microsoft WAIK or OPK Tools, to create Windows PE 2.x.
    - A licensed copy of BurnInTest Pro (trial or otherwise)
    - A licensed copy of Vista 32bit.

    This thread is not to be used concerning any other Windows PE builds than the stock ones made from the WAIK or OPK Tools. VistaPE, Winbuilder, BartPE etc does not apply to this project.

    In addition, this project makes use of a physical environment, which means I am using a real server and a real computer to run the program. No virutal environments are used at all. My WinPE I have created especially for BIT testing is deployed to the client via PXE.

    The actual computer being used is an AOpen MP965-D. Specifications for this computer can be seen in the link below. Testing of certain ports and devices are limited because of the hardware it contains.

    Notes to begin:
    - DirectX is not available in the PE. Because of this, a DirectX 9 error appears when launching BIT. Also, the video controller is not detected, even if the Video drivers are put into the PE. Because of this, you cannot do 2D, 3D or video tests.
    - Using the /w switch only shows CPU and Memory and greatly limits the amount of testing you can do. Use the /a switch to launch BIT.
    - the /a switch displays the following: CPU, Memory, Graphics (but is empty), HDD, CD, Ramdisk, Network and Ports.
    - USB says "not detected" and sees the USB Keyboard and Mouse as being PS/2.
    - Fortunately, under Disks, only the hard drive is shown to be tested. Do not have it test the X: drive, as this is the Ramdisk. This may likely cause an error in conjunction with the memory test. It may be helpful for Passmark to test these together, in order to find out the behaviour of running two tests on the same part.
    - Considering the limitations of the hardware I am using, having selected only CPU, Disk (c, RAM, Network and Optical Disk results in a PASS. Any additional items (especially default ones) will cause the test to fail, both because of the lack of loopback adapters, as well as limitations in the PE at this time. We only have loopback adapters for Serial and Parallel, and no USB loopbacks to use for testing.
    - Prior to starting the BITPro app, I had to format the HDD with Diskpart, or else the Disk test fails.

    That's it for now. I will try to find some ways to get the video tests to work. My company is not set to do a burn on audio testing, so I will only try that if I stumble upon that information.
    Last edited by Tripredacus; May-01-2009, 03:09 PM. Reason: disable smileys

  • #2
    Partial success at getting DirectX installed. Was able to get the "Would you like to install the Direct3D August 2008 update?" message. Tested only 2D and 3D. Also Graphics is still empty. Here is a log file. Some things to note:

    - BITpro sees the PE environment as Vista Ultimate.
    - the PE uses nearly 500MB RAM, which is why it only shows 512MB in AO (this is a guess).

    PassMark BurnInTest Log file  -
    Date: 05/01/09 11:53:37
    BurnInTest V6.0 Pro 1007
    Logging detail level: Normal
    Windows Vista Ultimate Edition Service Pack 1 build 6001 (32-bit),
    1 x Intel(R) Core(TM)2 Duo CPU T7500 @ 2.20GHz,
    1014MB RAM,
    System Name: MININT-KIMGOPT
    System Model: AWRDACPI
    Motherboard Manufacturer: AOpen
    Motherboard Name: i965GMx-IF
    Motherboard Version: 558EX10I630
    Motherboard Serial Number: 82200801JEB6
    BIOS Manufacturer: Phoenix Technologies, LTD
    BIOS Version: 6.00 PG
    BIOS Release Date: 10/03/2008
    CPU manufacturer: GenuineIntel
    CPU Type: Intel(R) Core(TM)2 Duo CPU T7500 @ 2.20GHz
    Codename: Merom
    CPUID: Family 6, Model F, Stepping B, Revision G0
    Socket: Socket P
    Lithography: 65nm
    Physical CPU's: 1
    Cores per CPU: 2
    Hyperthreading: Not capable
    CPU features: MMX SSE SSE2 SSE3 SSSE3 DEP PAE Intel64 VMX 
    Clock frequencies:
       Measured CPU speed: 2097.6 MHz
       Multiplier: x11.0
       Scalable Bus Speed: 200.0 MHz
       Front Side Bus: 800.0 MHz
    Cache per CPU package:
       L1 Instruction Cache: 2 x 32 KB
       L1 Data Cache: 2 x 32 KB
       L2 Cache: 1 x 4096 KB
    Total Physical Memory: 1014MB
    Available Physical Memory: 605MB
    Memory devices:
       - 512MB, 55438MHz, 
       - Not populated 
    C:  Local drive, NTFS, (74.53GB total, 74.44GB free)
    D:  Optical drive, PC Angel SB, DVD-RAM UJ-875S, CDFS
    X:  Local drive, Boot, NTFS, (0.03GB total, 0.03GB free)
    Intel(R) 82566MM Gigabit Network Connection (Speed: 1Gb/s)
    Keyboard Port: PS/2  connector
    Mouse Port: PS/2  connector
       USB not detected
    LOG NOTE:     2009-05-01 11:53:37, Status, PassMark BurnInTest V6.0 Pro 1007
    LOG NOTE:     2009-05-01 11:53:38, Status, Main Tests started
    LOG NOTE:     2009-05-01 11:53:38, 3D Graphics, 3D test starting: Duty cycle = 50. Test on primary monitor (0). (x,y) = (0,200). WxH = 300x200. 
    SERIOUS:     2009-05-01 11:53:38, 3D Graphics, DirectX Direct3D version required is unavailable
    LOG NOTE:     2009-05-01 11:53:38, 3D Graphics, 3D test: DirectX Direct3D March 2009 (d3dx9_41.dll) required
    SERIOUS:     2009-05-01 11:53:39, 2D Graphics, Error initializing DirectDraw
    LOG NOTE:     2009-05-01 11:53:48, Status, Test run stopped
    Test Start time: Fri May 01 11:53:37 2009 
    Test Stop time: Fri May 01 11:53:48 2009
    Test Duration: 000h 00m 11s 
    Test Name                   Cycles   Operations      Result Errors   Last Error
                  2D Graphics   0        0               FAIL   1        Error initializing DirectDraw
                  3D Graphics   0        0               FAIL   1        DirectX Direct3D version required is unavailable
    SERIOUS: 2009-05-01 11:53:39, 2D Graphics, SERIOUS: Error initializing DirectDraw (x 1)
    SERIOUS: 2009-05-01 11:53:38, 3D Graphics, SERIOUS: DirectX Direct3D version required is unavailable (x 1)


    • #3
      Again, I have not yet used WinPE, but while the normal way to install the DirectX Direct3D files is to run the Microsoft installer (this is what the BurnInTest installation package and BurnInTest do), you can also simply put the files in the same directory as BurnInTest (bit.exe). This is not the recommeneded approach, but might be worth a try if you need the 3D test and can't get the WinPE build process to include them. The files are (for V6.0.1007):

      d3dx9_41.dll (in
      d3dx9_41.dll (in

      Last edited by Ian (PassMark); May-01-2009, 10:42 PM.


      • #4
        I put the _39 (Aug200 and the _41 (Mar2009) into System32 and it resolved the pop-up screen that BIT displays when opening. It still could not initialize DirectDraw, but now getting a different error with the 3d test:

        SERIOUS: 2009-05-04 12:04:26, 3D Graphics, SERIOUS: Unknown DirectX error (x 1)
        I set it to do trace logging, but unlike the little disclaimer, it did not add any additional information that was helpful.

        LOG NOTE:     2009-05-04 12:04:25, Status, PassMark BurnInTest V6.0 Pro 1007
        LOG NOTE:     2009-05-04 12:04:25, Could not set up System events activity logging. 
        LOG NOTE:     2009-05-04 12:04:25, Could not set up Application events activity logging. 
        LOG NOTE:     2009-05-04 12:04:26, Status, Main Tests started
        LOG NOTE:     2009-05-04 12:04:26, Perform test: 3D Graphics at 50%
        LOG NOTE:     2009-05-04 12:04:26, 3D Graphics, 3D test starting: Duty cycle = 50. Test on primary monitor (0). (x,y) = (0,0). WxH = 300x200. 
        SERIOUS:     2009-05-04 12:04:26, 3D Graphics, Unknown DirectX error
        LOG NOTE:     2009-05-04 12:04:26, 3D test: Detailed error code (8876086a,0) 
        LOG NOTE:     2009-05-04 12:04:35, StopTests [7] 
        LOG NOTE:     2009-05-04 12:04:36, 3D Graphics, Stopping test 
        LOG NOTE:     2009-05-04 12:04:40, Status, Test run stopped
        Sorry, I got the error code here:

        Going off to do some more research!

        DirectDraw fails to initialize with code 0x80004005
        Last edited by Tripredacus; May-04-2009, 03:46 PM.


        • #5
          There are a lot of dependencies that Bit.exe (and dxdiag as they match) needs that are not present in the WinPE. I am testing these now and logging all changes I am making. Hopefully I can get some results soon. I will post an update when I get some more progress.


          • #6
            The failure of the video tests in Win PE 2.x come down to the following things that are not supported: .NET Framework, DirectX and some VB Runtime Environments.

            I have halted my attempts to get the video tests to work at this time. I talked with management and we agreed that the video test is not critical to our production process and we can skip it for now.

            Ian, I will email you the guide I started on, as well as my notes regarding the integration issues.

            Thanks for all your help.


            • #7
              The preliminary guide has been sent to Passmark for review.

              Just to note, everything is working on my end except for the script that automatically formats the hard drive. Diskpart is returning an error where it cannot find the text file that contains the script. I will be working on that today, but so far that is the only thing that isn't working in my implementation.

              EDIT: This is the corrected winpeshl.ini code. The startnet.cmd code is also incorrect, diskpart must be pathed both to its location and the script location.

              %SYSTEMDRIVE%\Windows\System32\setres.exe, "1024 768 32 1"
              %SYSTEMDRIVE%\Windows\System32\diskpart.exe, "/s %SYSTEMDRIVE%\Windows\System32\diskpart.txt"
              %SYSTEMDRIVE%\Progra~1\BurnInTest\bit.exe, "-x -r -c test.bitcfg"
              Last edited by Tripredacus; May-13-2009, 02:05 PM.


              • #8
                Yes thanks. We are looking at it.



                • #9
                  I recently created a script that automatically detects whether an optical drive is in the client system, then chooses a specific config file to launch BIT with. In my case, there are only 2 configs, one with and one without a cd drive. This code is in AutoIT:

                  $var = DriveGetDrive( "cdrom" )
                  If $var > 0 Then
                      FileCopy ("x:\Progra~1\BurnInTest\cdrom.bitcfg", "x:\Progra~1\BurnInTest\burn.bitcfg")
                      FileCopy ("x:\Progra~1\BurnInTest\nocd.bitcfg", "x:\Progra~1\BurnInTest\burn.bitcfg")
                  And here is the updated winpeshl.ini:

                  %SYSTEMDRIVE%\Windows\System32\wpeutil.exe, "initializenetwork"
                  %SYSTEMDRIVE%\Windows\System32\setres.exe, "1024 768 32 1"
                  %SYSTEMDRIVE%\Windows\System32\diskpart.exe, "/s %SYSTEMDRIVE%\Windows\System32\diskpart.txt"
                  %SYSTEMDRIVE%\Progra~1\BurnInTest\bit.exe, "-x -r -c burn.bitcfg"


                  • #10
                    Thanks for the post showing how BurnInTest configuration can be further automated. I will just say that there is some compromise betweeen automation and successful detection of faults. Specifically, if an optical drive device driver failed to load due to a hardware fault, then the wrong configuration may be chosen as probably no optical drive will be detected, and in this case no error will be shown for a dead optical drive.

                    In saying this, we have quite alot of requests to increase BurnInTest configuration automation to allow the reduction of the number of configuration files required. We plan to revisit this in the next major version of BurnInTest. No timeframe available at this stage.

                    Edit 1: Also, I forgot to metion that we now have a PC Test Kit that includes a Bootable USB Flash drive with BurnInTest (using WinPE). You can find information here: