No announcement yet.

trouble with loopback mode in USB2Test

  • Filter
  • Time
  • Show
Clear All
new posts

  • trouble with loopback mode in USB2Test

    Dear Passmark,

    I am using the USB 2.0 loopback plug with the USB2Test software. I'm trying to run tests under loopback mode, but each attempt fails with a string of "transceiver errors." Benchmark mode seems to work and I get reports of read/write data rates.

    I have tried several different USB 2.0 cables, including a pricey name-brand cable. I get exactly the same results. I have also tried selecting different data patterns. What are some possibilities as to why I cannot get loopback mode to work?

    I will also mention that the loopback plug error light is always on when attempting to run either the successful benchmark test or the unsuccessful loopback test. I have seen Passmark's explanation for this light.

    One more piece of information. Here is the USB path on my test platform:

    Intel southbridge --> on-board USB hub --> front panel dongle --> USB 2.0 cable --> Passmark USB 2.0 loopback plug.


  • #2
    Please see the information under the heading "Q. The red Error LED goes on. What does this mean?" at

    The problem is more likey on a front panel port (compared to a Motherboard connected port) due to the internal cabling. I would check the cabling from the motherboard is seated properly.



    • #3
      Is this the cause of failure for loopback mode?


      Do you believe the cabling to be the cause of failure for loopback mode? As I mentioned in my first post, benchmark mode seems to work fine, reporting no errors (only the plug itself signals any errors for this mode). Also, we have used this platform for months with a variety of USB devices and have seen no problems.

      Why would benchmark mode work and loopback mode consistently fail?

      Thanks for you time.



      • #4
        Do you believe the cabling to be the cause of failure for loopback mode?
        If you are concerned by the problem, you need to do some testing to confirm the cause. Are the cables from the motherboard header to the front port shielded? Did you try the back USB ports? Did you try another PC? Did you do a low level USB trace?

        As pointed out in the FAQ, these low evel errors do not represent data errors at the application level and often just lead to the packet being resent. So unless you are getting huge numbers of these errors it is likely that the error will go completely unnoticed by other USB devices.

        Benchmark mode doesn't report on transceiver errors. But if you have a lot of transceiver errors, you might notice the throughput being slightly down on what it should be.