Announcement

Collapse
No announcement yet.

prefix in log file

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • prefix in log file

    Is it possible to automatically add the customer name and serialnumber in the prefix of the logfilename? for example i have a customer named test and the serialnumber of the system is 123 so the log file should be saved like: test123.log This way it's easy to find a system back again.

  • #2
    There are a couple of ways to do this, the easiest is to probably set an environment variable before starting BurnInTest and then use this in the Log name prefix.

    From the helpfile:

    Log name prefix
    Specify "Log name prefix" if you wish to prefix the standard BurnInTest Text or HTML log filenames you can type a prefix string into the "Prefix" edit box. For example, if you want to prefix the standard BurnInTest log filenames with the text "SPECIAL_TEST_" then just enter,
    SPECIAL_TEST_
    This prefix to the log file name can use environment variables, such as %COMPUTERNAME%, %USERNAME%, %OS%, %PROCESSOR_ARCHITECTURE%. So, if for example you wanted to prefix log files with a test run description, the computerís name and the userís name, just enter,
    %COMPUTERNAME%_%USERNAME%_

    Comment


    • #3
      Hello Ian,

      Thanks for your reply, but how do i add the serialnumber i entered in the report information dialog to the log name? I tried %SERIAL% %SERIALNUMBER% but these ones doesn't work.

      Comment


      • #4
        For the computer name, there is a system environment variable for this value, so you just need to specify "%COMPUTERNAME%_" in BurnInTest Test Preferences->Logging, Log name prefix, and BurnInTest will expand the environment variable.


        The serial number is not so simple. It depends on what you want to use for this value. Normally you need a program that will set this string value (e.g. from User input) or get it somewhere off the system.

        Assuming you are writing a small program that will run before BurnInTest, then maybe the easiest way is to create a BurnInTest subscript file that is run on BurnInTest startup, called "bit-script-input.txt", and put it in the BurnInTest directory. Have your program write a line to this file that sets the Log file name, including the Serial number in it:

        SETLOG "123_BIT_log"
        SETSERIAL "123"

        At the same time, as you have the serial number, you may as well set this value for BurnInTest as well (shown above).

        Comment


        • #5
          This works ok for me in burnintest V6.1030 if i try to do this in burnintest 7 i get the following error:

          Line Number:1
          Line: SETLOG"123_BIT_log"
          Error:E008 - Invalid or unrecognised test name after command

          and my bit-script-input.txt only contains one line:

          SETLOG "123_BIT_log"
          Last edited by MKL; 08-16-2011, 01:20 PM. Reason: mistake made by me

          Comment


          • #6
            A lot of additional Test Preference settings can be scripted in BurnInTest 7.0. The Syntax for scripting the Log preferecnes has changed as follows:

            V6.0 syntax:
            SETLOG <Filename>

            V7.0 syntax:
            SETLOG LOG <parameter> NAME <parameter> PREFIX <parameter> TIME <parameter> REPORT <parameter> LOGLEVEL <parameter> TRACELEVEL <parameter> SUM <parameter> LINES <parameter> PERIODIC <parameter> FILE <parameter>

            So for BurnInTest 6.0 you should use:
            SETLOG "123_BIT_log"

            So for BurnInTest 7.0 you should use:
            SETLOG NAME "123_BIT_log"

            See BurnInTest help for further details.

            We will investigate supporting the V6.0 syntax in V7.0 for backward compatability.

            Comment


            • #7
              Thanks for your reply,

              I'm now trying to automate it a bit but when i run the following commandline in V7 it doesn't start the tests automatically:

              bit.exe -x Ėr -c test.bitcfg

              and i'm using the -r parameter

              Comment


              • #8
                The "Ėr" is not using the standard "-" character, your other paramaters are. Re-type the "-" character in front of the r or use the "/" character. ie. use:
                bit.exe -x -r -c test.bitcfg

                Comment

                Working...
                X