No announcement yet.

2D graphics error: "No operations reported in timeout period"

  • Filter
  • Time
  • Show
Clear All
new posts

  • 2D graphics error: "No operations reported in timeout period"

    I am having a recurring issue when using the BurnIn test software. I am getting an error in the 2D graphics test that says: “No operations reported in timeout period”. The test indicated It failed, but if I run the test again in the same device it finishes the same test with no errors.
    The error seems to happen almost immediately too, as it shows a log entry that says: “2D Graphics, Surface lost: restoring” and it repeats this same log entry several times each second until the end of the test. In three devices that I have found the error, it appeared in the first 0 to 3 cycles of the 2D graphics test.
    The logs for one of the devices looked like this:
    LOG NOTE: 2016-11-04 11:06:33, Status, Main Tests started
    LOG NOTE: 2016-11-04 11:06:33, CPU, SSE4a test(s) selected, but CPU feature not detected
    LOG NOTE: 2016-11-04 11:06:34, Video, Video test starting: Duty cycle = 50. Test on primary monitor (0). (x,y) = (310,400). WxH = 300x200.
    LOG NOTE: 2016-11-04 11:06:59, 2D Graphics, Surface lost: Restoring.
    LOG NOTE: 2016-11-04 11:06:59, 2D Graphics, Surface lost: Restoring.
    It then repeated the same log note until the test ended. For some reason, it seems like the software gets stuck in an operation and shows an error because of that.
    I am not sure what to take of this error, since it is not reliably showing up even in the same devices that saw the error before. How can I find the root cause of this issue?

  • #2
    Are you using the latest build of BurnInTest (8.1 build 1019) as there were some recent 2D test changes.


    • #3
      I was not using the latest version. I had 8.1 build 1018 installed. I have updated to build 1019 and I have not seen the same problem since. However, I cannot say for sure it is gone because even before updating it it wasn't as easy to reproduce. If it comes back again, I will make sure to let you know.

      One thing to note is that the first time I ran the test after upgrading, it have me issues with video playback. It was looking for a video in a certain path where I didn't have anything (something like user/sample videos) and of course it couldn't find it. But I just took a video file from the software folder and put it in that path with the name it was looking for and it worked fine.

      Thanks, and I will keep you updated if I find anything else.