No announcement yet.

Using com port after BIT shuts down in WinPE 3.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Using com port after BIT shuts down in WinPE 3.


    I am trying to use my com port after running BIT in WinPE 3, 64b. Now I can start WinPE, configure the com port, and all is well and working perfectly. I then start BIT and run a quick test, not the com port test though. Once the test is complete I close BIT and now my com port no longer works and I am unable to re-configure it again. I am guessing that BIT is re-configuring the port to meet its needs, but not resetting them when it's done. Any suggestions would be greatly appreciated.


  • #2
    There is no standard COM port setup.
    Each application is required to set it up as required by that application before using it. Baud, stop bits, flow control, etc..

    During startup BurnInTest collects a lot of system information. But doesn't change any COM port settings until the start of the serial port test. So I don't think this is the problem you have. In any case BurnInTest is just using the standard Windows API function. Meaning that there is no reason another application should be able to use the port later on.

    In my mind it sounds more like a device driver issue. Is this for an on board COM port, or is it an expansion card (e.g. a PCI-E card with multiple serial ports)?

    Once it stops working is there any error message from the other application. e.g. port locked, access denied, etc..


    • #3
      The COM ports are on on-board. Here is exactly what I am doing:
      1. Power on and boot WinPE 3.
      2. Type MODE, only the console (CON) is listed.
      3. Install MSPORTS.INF using DRVLOAD.
      4. Type MODE, now 4 COM ports and the console are listed.
      5. Start BIT and close it without running any tests, just open and close.
      6. Type MODE, only the console is listed again.
      7. Try to install the driver again and I get this error message,"DrvLoad: Unable to load x:\windows\inf\msports.inf (error 0x80070103)"

      I also tried this:
      1. Power on and boot WinPE 3.
      2. Start BIT and close it without running any tests, just open and close.
      3. Install MSPORTS.INF using DRVLOAD. Driver installs without any errors.
      4. Type MODE, only the console (CON) is listed.

      When the COM ports are present, I can configure them using MODE and send data to another PC.


      • #4
        I did some searching on the web for you.

        Error 0x80070103 in WinPE would seem to indicate that Windows has found a better match for the driver than the one you tried to load. Maybe this is just the standard error if you try and load the driver twice?


        • #5
          Any thoughts as to why I can't use the COM ports after running BIT?


          • #6
            Not really.
            Must be something to do with WinPE (or maybe your build or WinPE). We haven't seen anything like this in Windows proper.

            Debugging anything in WinPE is hard, as all the development environment is missing and iterating through multiple WinPE builds is very slow. If we had the system here to investigate with, and we really had to get to the bottom of the problem, and we had a few spare days, we would do a special build of BIT that could step through each of the steps in the startup process to try an isolate what operation provokes the problem. Or see if any other application would also provoke the problem. Even after working out what might be provoking it, it might turn out there is no solution (e.g. it is a bug in the serial port device driver code that only arises in WinPE).