No announcement yet.

RAM Test AWE (Locking memory for tests)

  • Filter
  • Time
  • Show
Clear All
new posts

  • RAM Test AWE (Locking memory for tests)

    I tried the section of locking memory pages to basically run the AWE RAM test. I am not able to change the administrator rights by going in the lock policy. Also ran the gpedit.msc but still not able to make changes in the lock policy. Added Administrator as user for the policy, but still no success.

    I am working on WES7 which is an Embedded version of Windows 7. Please advise how to proceed with changing the lock policy as I have tried a lot of stuff on web but still not able to proceed further.

  • #2
    In a quick test here we were able to run the AWE test in Win7 after adding the user group "Administrators" (as the current user was not the Administrator but BurnInTest has administrator permissions when run). If it won't let you add this group (object not found) you may need to click "Object types" button and check the "Groups" option.

    Changing this setting also required a reboot in order for it to take effect.


    • #3
      All that was done Tim. But anyways, I forced the policy using gpedit and now runs the test but gives me this
      'Error allocating RAM'.

      Now I am not sure how to makes sure that I have contiguous memory locations in RAM to make sure that this error does not occur and my tests continues. Please advise.
      Total RAM is 2034.2 MB.


      • #4
        If you check the "Log memory allocations" option in the RAM test preferences and turn the trace file detail to level 2 in the logging preferences there may be some more useful information logged about how much memory the test is trying to allocate and what might be stopping it.


        • #5
          It shows that the RAM for testing is less than the available RAM. The number of available RAM is less than being used for test. Is there a way I can reduce the RAM being used for test(i.e) lock down just 1MB if only 1.2 MB is available.


          • #6
            Could you please send us the .trace log so we can take a look at why it might be trying to allocate more memory than is available (contact details here). There is no way to manually set the amount of RAM for the test to use.

            The only situation in which this should be happening is if you are using an old version of BurnInTest (pre V7) or a process on the system is using up the free RAM while the test is being started. BurnInTest allocates the amount of memory under test based on the free ram so it will reduce the amount of memory used to quite a small amount.