No announcement yet.

bit_cmd_line_x32 errors with "illegal instructions" on Intel Quark

  • Filter
  • Time
  • Show
Clear All
new posts

  • bit_cmd_line_x32 errors with "illegal instructions" on Intel Quark

    I'm running the 32 bit trial version of BurnInTest on an Intel Quark platform. I immediately get "Illegal instructions" error and program kicks out. I'd disabled most of the tests in config text file and still get the error. Quark is based on Pentium 4 so I believe BurnInTest supports it. Any idea why I'm getting this error?

  • #2
    This sort of error would generally indicate the executable isn't compatible with the system. SSE2 support is required to run BurnInTest, and it looks these chips don't support SIMD instructions, so this would the likely reason for the failure.


    • #3
      Tim, thanks for you prompt response. I've included the actual error messages. Do you still believe that the error is due to Quark processors not supporting SSE2?

      [ 272.145660] grsec: Illegal instruction occurred at 0810885f in /home/burnintest/32bit/bit_ cmd_line_x32[bit_cmd_line_x3:4242] uid/euid:0/0 gid/egid:0/0, parent /bin/bash[sh:3086] uid/e uid:0/0 gid/egid:0/0
      [ 272.167138] grsec: denied resource overstep by requesting 4096 for RLIMIT_CORE against lim it 0 for /home/burnintest/32bit/bit_cmd_line_x32[bit_cmd_line_x3:4242] uid/euid:0/0 gid/egid: 0/0, parent /bin/bash[sh:3086] uid/euid:0/0 gid/egid:0/0
      Illegal instruction


      • #4
        These error messages seems to be related to grsecurity, we've never had any other support issues with such errors nor have we tried any Linux distributions that use it (that we know of) so it's possible that grsecurity is preventing the execution. The fastest way to check would be to disable this package or exclude BurnInTest (if possible) from its regulation.

        Intel don't seems to specifically mention what instructions are supported but the wikipedia pages suggests no SIMD support ( You should be able to check the cpuinfo on the system (cat /proc/cpuinfo) and see if there is an "sse2" entry in the flags value.