No announcement yet.

Advanced Network Test

  • Filter
  • Time
  • Show
Clear All
new posts

  • Advanced Network Test


    I have two Realtek PCIe GBE Family Controllers
    - Realtek RTL8111G

    I am using Windows 10 IoT Enterprise.

    I team the two controllers using powershell:

    PS new-netLBFOTeam -name SOMETHING -TeamMembers "Ethernet", "Ethernet 2" -TeamingMode LACP

    I have internet connection and everything seems fine.

    But when I run Advanced Network test, I am not receiving or sending any data.

    Click image for larger version

Name:	Capture1.PNG
Views:	1
Size:	5.9 KB
ID:	35287Click image for larger version

Name:	Capture2.PNG
Views:	1
Size:	20.8 KB
ID:	35288

    I have internet and can reach the Endpoints with ping and see them in Display List.

    If I remove the team, and repeat the same test, everything works fine.

    Any idea what I am during wrong?

    Best regards

  • #2
    We haven't tested this for quite some time but last time we did I believe the test functioned with teamed NICs. Does the standard network test work?


    • #3

      Thanks for your reply

      I have started from scratch and on my small network without firewalls and such.

      I have two computers and 1 switch. 1 computer has two network cards(Realtek) and 1 computer is running Endpoint with two IP's.

      The switch is factory reset.

      Without a team, the computer can do both standard og advanced tests.

      if I make a team (LACP), I can do the standard test, but the advanced test does not work.
      - I can still ping the endpoints and see them in "Display Endpoints".

      Best regards


      • #4
        Does the connection appear on the endpoint when you run the test but the test window in BurnInTest is not updated?

        At the moment the behaviour we're seeing is that the test starts and data is transferred but because of the way the network statistics are read by BurnInTest there is no matching entry for a teamed network card.

        As windows doesn't really have much knowledge of what constitutes the team it doesn't seem possible to get this information at this point. What we're going to do is make sure the test window is updated with a bytes sent / received count from BurnInTest if the network performance counters so the test will be observed as running.

        However this means that there will be no target load balancing on a teamed group.
        Last edited by Tim (PassMark); Jun-16-2016, 12:33 AM. Reason: More info


        • #5

          Again thanks for your reply.

          My endpoint station was never attached to a screen, since before the "Teaming", it was always working.

          But I attached a screen and ran the test again.
          - The computer duing the BurnInTest is listed in the endpoint application, but still no data is shown on the computer doing the test.

          But how do I approach this? I want a passed test, that I can show to the costumer, but the test will always fail with this teaming.

          Best regards


          • #6
            The just released 8.1 build 1016 will now update the sent/received count for a teamed NIC,


            • #7
              Hello again

              Tested today with new version

              Some succes

              Click image for larger version

Name:	BurnInTestTeamAdapter.PNG
Views:	1
Size:	6.2 KB
ID:	34981

              Now the test can succed

              Thank you

              Best regards