No announcement yet.

Disk Checkup Stops Working After a Year

  • Filter
  • Time
  • Show
Clear All
new posts

  • Disk Checkup Stops Working After a Year

    I've been using Disk Checkup for sometime now. A couple of weeks ago, I did a system restore because of a problem involving Roxio CD/DVD Creator uninstalling properly. When I attempt to run Disk Checkup, I immediately get an error message stating "Errors Initializing Disk Checkup" > There were errors trying to gather the SMART info.

    The PC is running fine. I've looked to find something that appears to be different following the restore and cleanup. In viewing Disk Management under Manage My Computer, I noticed that the C:\ no longer appears as the drive letter for my hard drive. When I attempt to add a drive letter, my choices don't include C. I ran Diskpart and it verified that as well. However, Explorer and all other applications recognize c:\ and work fine. I also ran the WMDiag utility and I get a "Success" screen following the run. I wanted to attempt to add the "C" drive letter in Diskpart, however, I thought that I read that Windows would not accept a drive letter on the boot drive for some reason. I really want to get back monitoring my disk health (this computer is almost 7 years old). Up till now, it's been perfectly healthy.

    One final point, I also use PC Wizard 2008 that seems to detect the SMART drive version (1.1) and the info produced. It generates an abbreviated report as to the overall disk state (Health 93%, Performance 98%). I've only been using PC Wizard a couple of months. I trust the data from Disk Checkup and want to continue using it.

    Any suggestions on what I need to tweak to get this program back up and running?

    SA Jack

    Running: HP Pavilion, AMD Athalon 1.3GHz, 512Mb Ram, Win XP Home SP2, Win Firewall, Avast Anti Virus, Win Defender

  • #2
    What version of DiskCheckup are you using?
    How many hard drives do you have? How many partitions / drive letters are on these drive(s)

    If you add the command line paramter DEBUGMODE then a log file will be produced.
    So executing this,
    C:\Program Files\DiskCheckup\DiskCheckup.exe DEBUGMODE

    Makes a file called,
    C:\Program Files\DiskCheckup\DiskCheckupLog.txt

    Can you E-mail us this file, DiskCheckupLog.txt


    • #3
      Thank you for the quick response.

      I'm running:
      Disk Checkup 2.1
      I have 1 hard drive and it has 1 partition
      Diskpart shows CD (D, DVD (E, and USB (F

      I ran the command line sequence as you noted. However, I received the same error message as I indicated in my initial e-mail.

      I'm sending you the diskpart log via e-mail to show you the fact that there is not only no drive letter for what should be c:\, but under the "Info" column, it is blank as well. It should reference "system" I believe.

      Hope this is of help.

      Thanks again. SA Jack

      SA Jack

      Running: HP Pavilion, AMD Athalon 1.3GHz, 512Mb Ram, Win XP Home SP2, Win Firewall, Avast Anti Virus, Win Defender


      • #4
        What is the status of this issue? Because I have the same problem. I've been using DiskCheckup before but since I reinstalled Windows, DiskCheckup 2.1 fails with a "There were errors trying to gather the SMART info."

        Here are some parts of my debug log file:
        SmartDll: 20:52:34 11-févr.-2008 - GetSMARTInfoNT()
        SmartDll: 20:52:34 11-févr.-2008 - Drive 0:
        SmartDll: 20:52:34 11-févr.-2008 - Drive 1:
        SmartDll: 20:52:34 11-févr.-2008 - Drive 2:
        SmartDll: 20:52:34 11-févr.-2008 - Number of extent: 1
        SmartDll: 20:52:34 11-févr.-2008 - Opening physical device #0
        SmartDll: 20:52:34 11-févr.-2008 - Opened.
        SmartDll: 20:52:34 11-févr.-2008 - DeviceIoControl(IOCTL_DISK_GET_DRIVE_GEOMETRY) succeeded. Device #0 (Drive "C:") capacity: 76316 MB
        SmartDll: 20:52:34 11-févr.-2008 - DFP_GET_VERSION failed.
        SmartDll: 20:52:34 11-févr.-2008 - Drive 3:
        SmartDll: 20:52:34 11-févr.-2008 - Drive 24:
        SmartDll: 20:52:34 11-févr.-2008 - Drive 25:
        SmartDll: 20:52:34 11-févr.-2008 - 0 SMART enabled devices found.
        SmartDll: 20:52:34 11-févr.-2008 - SmartDll_Init[3612]: err!=0 (err = 1)
        DiskCheckup: 20:52:34 11-févr.-2008 - InitDialog[560]: SmartDll_Init error = 1



        • #5
          There are many reasons why the SMART data might not be available. So there will not be 1 solution to this issue. Some example of reasons include,
          1) BIOS doesn't support it
          2) The hard drive doesn't support SMART
          3) The wrong motherboard drivers are installed.
          4) You are using an older version of Windows which require specific additional DLLs to be installed before it could work.
          5) You are using Vista but not running as elevated admin

          From memory I think our conclusion was that the previous issue in this thread was a system configuration issue (the systems was missing C: drive for reasons we couldn't explain).