No announcement yet.

Zoom 7.0/7.1 issues

  • Filter
  • Time
  • Show
Clear All
new posts

  • Zoom 7.0/7.1 issues

    I have both 7.0 and 7.1 in use. I use 7.0 to index my website for my website search facility (ASP.NET) and 7.1 to index my website for my mobile apps (uses the JS option).

    I wouldn't mind using 7.1 for the website but can't get the output files from 7.1 to work on the website. Presumably something needs changing in the search page?

    Also, this morning when I went to my laptop (on which I have 7.0 - 7.1 is on my desktop) I couldn't get it to index my website. I claimed it wasn't able to find it. A bit strange as 7.1 on my desktop searched it straight away.

    Any help I can get with these two issues would be much appreciated. Zoom search is a great product and generally does what it says on the tin but I don't need to alter it much and therefore can't claim to be super knowledgeable about it.

  • #2
    V7 is pretty old now.
    Is there any chance you can try V8?

    There isn't a huge difference between V7.0 and V7.1. Are you using the same configuration files for both?

    For the indexing issue can you post the log file?


    • #3
      Yes I'm using the same configuration files.

      Here is a screenshot of the log tab. My website's URL is I just tried to index the site again and used the same machine to open the remote desktop and give myself permission to index the site. Also I have browsed to the index page with no problem.

      Click image for larger version

Name:	zoom.png
Views:	111
Size:	112.6 KB
ID:	54600


      • #4
        So that page you started the spider at doesn't seem to exist.

        Web server returns a 302 response code (which means content was moved) and returns this redirect URL to a login page.

        I tried this with V8 however and it follows the redirect. So it should still work. (not sure about V7)

        But the web site behaviour might be different if the client is already logged in however? Are you getting Zoom to login with user name and password? Or do you have an exception to the login for certain IP addresses or User Agents?

        This is what happens in V8 with a default config.
        Click image for larger version

Name:	zoom-indexing.png
Views:	138
Size:	245.3 KB
ID:	54602
        There is a broken link to the privacy policy page, but that is a different issue.


        • #5
          The website config file has a setting which allows unrestricted access and I just set this to 1 rather than 0 when I want to index the files and as soon as I have finished switch it back to 0. 7.1 on my desktop worked fine, but 7.01 on my laptop (which usually works fine) just couldn't see it for some reason.

          What do I need to do just to get 7.1 working on the website? I would have thought it would work identically but it doesn't.


          • #6
            We stopped supporting ASP.NET and V7 some time ago. (V7.0 is from 2014, so nearly 10 years old now).

            ASP Classic and ASP.NET (webforms) both effectively got killed by Microsoft. They moved on to .Net Core. Their product naming is pretty terrible and confusing.
            They also killed Silverlight, MAUI, VBS, Metro, UWP, and bunch of other stuff. So very hard to trust them at this point.

            The old ASP.NET server controls are still on our web site however. So maybe you just need to update to the V7.1 version?

            But PHP is probably a better option at this point.


            • #7
              Great, I'll get that installed and try it. Could solve both problems.


              • #8
                Thanks David. Installing 7.1 ASP.NET server controls solved that issue, so I'll use 7.1 for everything now. Thanks for that assistance, it's much appreciated.