No announcement yet.

4.3.2 test #4 wrong progress bar

  • Filter
  • Time
  • Show
Clear All
new posts

  • 4.3.2 test #4 wrong progress bar

    using v4.3.2 I noticed that when test#4 (Moving inversions, 8 bit pattern) reaches 100% it continues with different patterns shown and progress at 100% all the time.
    When it goes to test #5, the progress bar is again normal.

    (same PC as before, i5-2320)


  • #2
    It is the same with other test, like #8.

    Also the overall progress bar "Pass" shows 100% for quite a while.

    Bug in the progress bar code?


    • #3
      More data:
      When test #4 is running and reaches 100%, it continues to execute.
      During that time the overall Pass indicator goes from 24 to 37%.

      It is similar with test #7: After the test reaches 100% it continues and the Pass value goes from 82% to 100%.
      Judging by the Testing and Pattern values, the test #7 executes once again (the memory ranges repeat again from 0 to 4 GB, and also the patterns).
      After that tests #8 and #9 execute and the overall Pass indicator is at 100% all that time.

      Tests #5 and #6 did not show this problem.

      So it seems that:
      - both the overall and individual test progress bar go to 100% too early.
      - test #7 is executed two times


      • #4
        Thanks for the details.

        We believe we have fixed an incorrect calculation of the test progress for Test 4, which indirectly affects the progress calculation for the other tests. Please let us know if you would like to test a pre-release build for us.


        • #5

          I just tested v4.3.3 and:
          - first two test run for a few second until 100% and then about a second or two, while the progress indicator stays at 100%
          -test 4 is OK
          - test 5 continues to run after reaching 100% for about two minutes. In that time the overall progress indicator goes from about 20 to 30%
          - keyboard doesn't seem to respond (tried the ESC and C keys)
          - power off button turns the PC off immediatelly, I expected a 4 second delay that is usual when no OS is running


          • #6
            KBD also does not work in 4.3.2, while it works with memtes86+ v4.20 (the "other" memtest)


            • #7
              There are known issues with some motherboards when USB keyboards are used. Especially on new Macs. These can't really be fixed in the V4.x code without a huge development effort. See this old post for details.

              In addition to this, how response the keyboard is depends on what test is running. Some tests check for keyboard input more often and thus seem more response.

              Was this a USB keyboard?
              Can you try just holding the 'C' down, for 3 or 4 seconds to see if it registers the key press.
              Did you try a key press in at a few different times during the tests?

              The situation should be completely resolved in V5, which used a native USB interface driver, rather than a BIOS port 60 emulation (like V4 does). Does this machine have UEFI, that would allow you to try V5?


              • #8
                It is a PS/2 keyboard.

                I tried v4.3.3 now.

                After start I pressed C for many times, but only when test #4 started did the menu appear.
                During execution of test #4 the response to pressing the C key was instant. Then even if I selected to run test #3, the key still worked.

                It is onyl after fresh start that the keyboard is not read. Until test #4 starts, then it works. I did not wait for later tests after #4...

                If it matters: I start memtest from an USB stick with grub4dos.