No announcement yet.

Possible faulty CPU?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Possible faulty CPU?

    Hello everyone,

    I'm building a new rig, using the following components:
    Board: GA Z390 Designare
    CPU: Intel Core i7-9700K
    RAM: 16GB Crucial Ballistix 3200MHz (1x16GB)

    BIOS boots fine, and I've always been able to POST. But I've been having lots of issues with even installing Windows on the machine.
    So I started looking for possible hardware faults. I ran memtest86 v8.2, and got the following RAM errors:

    I tried switching RAM slots, but the results were pretty consistent: thousands of errors, always on Test 6; only on CPU 7.
    I then RMA'd the RAM stick, and got a new one exactly the same as the previous: 16GB Crucial Ballistix 3200MHz (1x16GB)

    Installed the stick, ran memtest86 again, and to my surprise, the results were exactly the same.
    Again, tested on different slots. Every time, the errors come up on Test 6, CPU 7. All other tests pass, on every other CPU.

    Am I just unlucky picking RAM, or is it safe to assume I need to RMA my CPU?


  • #2
    In the menu of Memtest86 you can select the CPU cores to use.
    Try testing on just 1 core.


    • #3
      Hi David, thanks for your response.

      What I did since my firt post, was to run isolated tests. I ran test 6 on every individual core separately, for 2 passes each.

      CPUs 0 to 6, no errors.
      CPU 7 reported errors right from the start, until memtest86 eventually halts with a "too many errors" message.

      What should I make of this? It's my first time using memtest86, and I'm a bit unsure if I should point fingers at the CPU right away.


      • #4
        As you have already swapped the RAM, and only one core has a problem, then yes, the CPU is now suspect.


        • #5
          Ok, thanks a lot for helping me make sense of this.