No announcement yet.

Memtest Errors + Freezing

  • Filter
  • Time
  • Show
Clear All
new posts

  • Memtest Errors + Freezing

    Hi all

    These are my PC specs (new build September 2019 working perfectly until now;
    • i9 9900k (Stock)
    • Rtx 2080s
    • z390 Aorus Master (F9 Bios but have now flashed it to F10)
    • 32gb Corsair Vengeance 3200mhz
    • Samsung 860 EVO SSD (250gb)

    On Sunday evening my PC BSOD whilst I was playing Destiny 2. I had been playing the new COD and Apex for around four hours prior with no issues. I can no longer get into Windows following multiple different BSOD codes which appear straight after the Mobo splash screen starts to transition to Windows 10 with the spinning wheel. Immediately as it gets to that point I get a BSOD. Sometimes it will try say "Preparing Automatic Repair" and then BSOD. My Mobo is showing that all peripherals are recognized. After multiple different troubleshooting attempts i believe that I have ruled out a bad boot drive as I cannot even boot a Windows Installation USB with all other storage devices disconnected apart from the USB. An assortment of BSOD codes I have seen are below;
    • Pagefault in non page area
    • Irl not less or equal
    • Unexpected kernel mode trap
    • Ntfs.sys
    • System thread exception not handled
    • Memory management
    • Class pnp.sys
    • Inaccessible boot device
    After seeking further advice some think it could be a RAM issue. I have tested booting with both sticks in different slots i.e A1+A2 & B1+B2, one stick in different slots etc but with no success. Somebody suggested that I run Memtest86. I have it installed onto a USB. Memtest will often freeze after varying different lengths of run but usually around 2-4 minutes of the first phase of testing. However, if the test manages to reach Phase 1 Test 6 it gives hundreds and sometimes thousands of errors. Please see below a screenshot of some of my results. Please note that I have been unable to complete a full run as Memtest freezes all the time. The longest run I have been able to achieve is 15 minutes. I have tried with standard multi core settings, sequential and single CPU core (Core 0).

    Slot A1 Test 1 -
    Slot A1 Test 2 -
    Stick 2 A1 Test 1 -
    Stick 2 A2 Test 1 -

    Is this evidence of bad ram or something else? Please note that this is a new build PC which had been operating flawlessly since the first week of September. I have ordered replacement RAM and an SSD (to be safe) which I will be able to install later tonight. Any advice would be greatly appreciated.



  • #2

    SSD and RAM replacements have made no difference, Bios recognises all peripherals but as soon as the Aorus splash screen starts to transition to Windows it BSOD. I have downgraded bios to see if that helps with no joy. CPU has been reseated and visibly checked for bent pins and nothing (it has been running perfectly fine for two months). I am at my wits end now. It has to be Mobo or CPU right?


    • #3
      Can't be the SSD if MemTest86 & Windows boot drive run also fail.

      From the screen shots I would have blamed the RAM. But it is very unlikely that both sticks have failed in the same manor. And if you have now replaced the RAM with completely new RAM, that rules out the RAM.

      So yes, next most likely cause is the CPU.


      • #4
        Thanks for the reply. Somebody else has suggested to me it may be the Mobo but I cannot get my hear around the reasoning behind each. What points you to CPU?


        • #5
          Motherboard is just the wires between the CPU and the RAM slot. There isn't much to suddenly go wrong which would effect all slots..


          • #6
            The only slot that displayed errors on both sticks was A1 as I stopped testing after that and I got fed up of the test freezing due to the Uefi bug. That's not to say the errors would not have shown up in the other slots had I persisted though.


            • #7
              I think I am going to see if any of the local repair shops have a 9 series Intel board and would allow me to try my CPU in it. That should give me a definitive answer.


              • #8
                Power surge without a surge protector. CPU and secondary SSD are kaput.


                • #9
                  Glad to hear you solved it.
                  It would be unusual for something like a lighting strike to leave the PSU untouched but blow up the CPU. Whatever was the cause, I wouldn't be too sure that a surge protector would have stopped it.