No announcement yet.

recover usb

  • Filter
  • Time
  • Show
Clear All
new posts

  • recover usb

    Ok so after I used memtest86 the space on my usb for small. i followed the steps to recover it with imageUSB and after that my usb doesn't come up.I selected the Zero UFD option & Run. I tried the usb in a different PC. Still can't see it. The option to safely remove the USB comes up so it detects it to a certain point. I tried re-installing the drivers for the USB. It didn't work.

  • #2
    Did you try to reformat it from the Windows,
    Computer Management / Disk Management window?


    • #3
      Thank you. That worked. I can't believe it was so simple >.>


      • #4
        It didn't really worked. I opened Disk Management. Formated it to NTFS format, the file and folder compression was unticked. Now it says that the status is Healthy (active, primary partition). If I change the drive letter path then I can use it on my PC but as soon as I try it in another PC it doesn't come up. If I plug it back to mine its not working again.

        edit: It was originally unallocated and I right clicked it and made a new simple volume. The other volume options are spanned, striped and mirrored volume, or convert it to dynamic or gpt disk.


        • #5
          If you got is working and then at some later point it failed, then there is the possibility that the drive is bad.

          Try reformatting it again, but just do it as a simple FAT volume.


          • #6
            In Computer Management it shows that its a Basic drive. It should be removable. Its like my PC things its a hard drive. I can assign it to letter but it will work like a hard drive. Can I convert it back to a removable state thingy or its a goner? Its a cruzer edge if thats matter.


            • #7
              What version of Windows are you using?


              • #8
                windows 7 64bit.


                • #9
                  I did some searching for you and it looks like it a recent problem on newer Sandisk Cruzer flash drives.


                  It seems that Microsoft's Windows 8 'To Go' feature resulted in a change to the behaviour of some drives so that they don't display in Windows as an external removable device. Instead, they function in Windows like an internal hard drive and appear as a Local Disk.

                  Windows To Go is a feature in Windows 8 Enterprise that allows Windows 8 Enterprise to boot and run from mass storage devices such as USB flash drives and external hard disk drives. It is intended to allow enterprise administrators to provide users with an imaged version of Windows 8 that reflects the corporate desktop and as such is aimed at enterprises.

                  Microsoft has set up specific testing requirements that the USB drive manufacturer must meet in order to be a supported device. Currently there are only a few USB Flash memory devices listed as supported by Microsoft for Windows To Go. One of them seems to be your Sandisk USB drive.

                  See also,

                  Sandisk did have a web page up on their site detailing this, but it has been taken down. Leaving people in the dark. This new behaviour breaks a bunch of stuff on Windows 7, Vista and XP. There are a bunch of proposed solutions on other sites, but the general recommendation seems to be to not purchase the Sandisk drives (unless you are going to use the 'To go' Win8 feature).


                  • #10
                    Ah I see. I used it to install windows 8 but went back to windows 7. It took me forever to make it into a bootable device because it wasn't compatible with Microsofts iso tool.

                    Thanks for all the help man. I'm just not gonna bother with Sandisk drives anymore. It was was so cheap so I don't really mind.