No announcement yet.

Unable to set screen size

  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to set screen size


    after collecting the hardware information memtest86 displays a black screen and does not continue.
    Checking the log file showed that the screen resolution is too high and memtest fails to reset it.
    Is this a bug in memtest86 or did I miss anything?
    I've noticed that the latest version got a feature that could be the source of this error:
    Release Notes of 8.4: "Added fallback when failing to set the menu screen size to the max supported resolution."
    Please find the log file attached.

    Best regards
    Attached Files

  • #2
    I'm experience the same issue. The black screen happens shortly after "Checking for multithreaded support" text appears (something close to that, forget exact wording).

    I also tried adding my board to the blacklist.cfg file with FIXED_SCREENRES but it does not appear in the log to have successfully picked up my entry.

    ASRock x370 Taichi, Bios version 5.10
    Here's the line I entered in blacklist.cfg: "ASRock X370 Taichi",ALL,EXACT,FIXED_SCREENRES

    And here's a snippet of the logs of the loaded blacklists:
    "ProLiant DL325 Gen10",ALL,EXACT,DISABLE_MP
    "ProLiant DL385 Gen10",ALL,EXACT,DISABLE_MP

    My entry should have been in this snippet.


    • #3
      Apologies, I copied from the blacklist.cfg and not the log in that last bit.

      Here is the relevant log info (I commented out the majority of the other boards in blacklist.cfg to make it more readable for myself):
      2020-04-14 14:07:11 - Found blacklist file
      2020-04-14 14:07:11 - [BLACKLIST] Adding "LNVNB161216" (BIOS: "", FLAGS: to blacklist
      2020-04-14 14:07:11 - [BLACKLIST] Adding "GA-990FX-GAMING" (BIOS: "", FLAGS: 2) to blacklist
      2020-04-14 14:07:11 - [BLACKLIST] Adding "X399 SLI PLUS (MS-7B09)" (BIOS: "", FLAGS: 2) to blacklist
      2020-04-14 14:07:11 - [BLACKLIST] Adding "0F685W" (BIOS: "", FLAGS: 80) to blacklist
      2020-04-14 14:07:11 - [BLACKLIST] Adding "ProLiant DL325 Gen10" (BIOS: "", FLAGS: 4) to blacklist
      2020-04-14 14:07:11 - [BLACKLIST] Adding "ProLiant DL385 Gen10" (BIOS: "", FLAGS: 4) to blacklist
      2020-04-14 14:07:11 - [BLACKLIST] 6 boards added to blacklist
      2020-04-14 14:07:11 - Console Control protocol workaround enabled
      2020-04-14 14:07:12 - Number of console modes: 4


      • #4
        There seems to be an increase with screen resolution issues since the v8.4 release. Does the issue occur for v8.3 as well?

        Nevertheless, we looked into the code and attempted to make it more robust. Please give the following build a try at your convenience:

        If possible, please upload or paste the MemTest86.log file as well.


        • #5
          Thanks for looking at the problem again.
          Unfortunately I don't have the 8.3 release. Is there a page I can get it from?
          The link you posted above does not work, I get a 404.


          • #6
            I'm getting similar error [thou my screen doesn't go blank, it just hangs] - see thread

            The link in previous Keith post has extra space at end [shows as '%20'], try




            • #7
              ahhh, I'm so stupid, didn't notice that thanks sugob


              • #8
                pictureon - That's ok. Knowing your stupid probably means your not - not knowing your there's a problem!


                • #9
                  sugob - thanks

                  keith - I've tried it with version 8.4.1003 and I don't get screen size error any more. But the screen stays blank after the "Checking for multithreaded support" text was shown. I've attached the log file for completeness.
                  After setting the graphics mode it stopped working.
                  Attached Files


                  • #10
                    Thanks for the logs.

                    Sorry about the broken link. Thanks sugob for the fixed link.

                    It looks like the issue has been introduced in v8.4 and reported by many users since the release.
                    We compiled a debug build with additional debug output, as well as disabled setting of the graphics resolutions.

                    Here is the build if you want to give it a try:


                    • #11
                      FYI I couldn't get MemTest86 V8.4 Free Build: 1003 (64-bit) to run on my system due to resolution issue. I had to blacklist my motherboard "AB350M Pro4" with
                      "AB350M Pro4",ALL,EXACT,FIXED_SCREENRES
                      to get it to work. Log attached from successful run.
                      Attached Files


                      • #12
                        Thanks for sharing the new build Keith. I've tried it version 8.4.1004 today.
                        No black secreen any more, instead the computer reboots at this point


                        • #13
                          Thanks for the log files.

                          We are still trying to isolate the issue.
                          If possible, please give the following build a try and post the resulting log file.



                          • #14
                            Thanks for the new build.
                            Unfortunately the same behavior as with 1004.
                            See the log file attached.
                            Attached Files


                            • #15
                              Thanks for the logs.

                              As expected, it appears to hang when attempting to set the screen resolution via the UEFI firmware. We have made some changes to avoid changing the resolution. However at the end, we may have to blacklist the board.

                              Can you give the following build a try: