Announcement

Collapse
No announcement yet.

The Surface Pro X can‘t run Memtest86

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • The Surface Pro X can‘t run Memtest86

    As you can see in the photo,I made a USB flash drive for Memtest86 and it worked on my X86 laptop, but running it on the Surface Pro X stuck on this interface, telling me if it was ARM compatibility or if Microsoft was blocking my CPU information. I remember memtest86 9.0 is compatible with ARM PC, right?

    Hope to find a solution :D

  • #2
    We have tested MemTest86 in-house with Surface Pro X (with an ARM CPU), so the Surface Pro X should be supported. If you are using V9.0 there have been a couple of releases since, make sure you are running the latest release of MemTest86. If you believe there is still an issue with MemTest86, you can send in the debug logs and we can take a look.

    Comment


    • #3
      Originally posted by Richard (PassMark) View Post
      We have tested MemTest86 in-house with Surface Pro X (with an ARM CPU), so the Surface Pro X should be supported. If you are using V9.0 there have been a couple of releases since, make sure you are running the latest release of MemTest86. If you believe there is still an issue with MemTest86, you can send in the debug logs and we can take a look.
      Thank you for your reply. I downloaded the latest memtest from dowload page. It should be version 9.3. I am not sure if it can get log files in my case, I will check later,and send it out.

      Comment


      • #4
        Or do I need to set some parameters for USB to work properly on the Surface Pro X?

        Comment


        • #5
          Hi all ,this is my log ,please take a look.
          Attached Files

          Comment


          • #6
            Thanks for the logs.

            The hang was caused by failing to measure the CPU clock speed properly.
            We made some changes that may fix the issue. We don't have your exact system but you can give this build a try if you like:

            https://www.passmark.com/temp/memtes...b-9.3.1008.zip

            Comment


            • #7
              Hi it's me again, I am here with you to give me the version of the validation, and found that can enter into the memtest logo interface, but found that I can't move my mouse, computer did not automatically start testing, I tried the mouse, press the keyboard, touchpad, according to the touch screen, all can't move my mouse, seemed to hang in the interface.

              And this is my log, please look at it again,thanks for you all T-T.
              Attached Files

              Comment


              • #8

                Comment


                • #9
                  Guys, I'm still here, waiting for a response T-T

                  Comment


                  • #10
                    Thanks for the logs.

                    We included some additional logging. Can you give this build a try and send the logs as before:
                    https://www.passmark.com/temp/memtes...b-9.3.1009.zip

                    Comment

                    Working...
                    X