No announcement yet.

MemTest86 on aarch64?

  • Filter
  • Time
  • Show
Clear All
new posts

  • MemTest86 on aarch64?

    I saw that MemTest86 gained support for ARM64 (aka aarch64), and I'm curious to try it. It even seems like some other folks have used it successfully. I can't figure out where to get the actual binary though.

    I grabbed the latest release, mounted it to extract the files for UEFI booting, but have only found BOOTIA32.efi and BOOTX64.efi. I even tried booting my ARM64 system with BOOTX64.efi with no luck. These have got to the the x86 and x86_84 binaries, right?

    So, am I blind? Did I miss an obvious download link? Can someone point me in the right direction?


  • #2
    Both ARM and x86 versions are in the same download package (This is starting from Version 9.0, 10/Feb/2021).

    Download page is here,

    The file containing the ARM executable on the boot drive is, BOOTAA64.efi


    • #3
      Looks like I had an old version of the zip file sitting around in my downloads folder (older than the introduction of aarm64 support). I found it, and it booted right up.

      Not everything worked (single core, no SPD or ECC info), but it got the job done.

      Thanks for adding ARM64 support!


      • #4
        Not sure what hardware you are using, we we noticed some vendors disable multi-threading in UEFI BIOS on ARM. So only single threaded testing is possible on some hardware.

        SPD also isn't available on some hardware. Either the motherboard doesn't have SMbus support, or the memory chips are soldered to the motherboard and don't have a SPD chip.

        We haven't see any ARM platform with ECC RAM support. They probably exist, but we don't have any test hardware like this.