No announcement yet.

7950x, 128gb DDR5 — Test 8 errors.

  • Filter
  • Time
  • Show
Clear All
new posts

  • 7950x, 128gb DDR5 — Test 8 errors.

    Hi all.

    Context first:

    I’m new to MemTest86 but I have been testing with it since experiencing multiple BSOD on a new build, including:


    MemTest threw up 1000’s of errors.

    Turns out my original Corsair RAM was not on the QVL list (as I thought it was) so I replaced it with compatible, matching Kingston RAM two days ago.

    Here are my current specs:

    * Ryzen 7950x
    * 128GB DDR5 Kingston Fury Beast RAM (5600)
    * Asus X670-P mobo
    * RTX 4090
    * Win10

    There are NO OVERCLOCKS on both CPU and RAM. No settings have been adjusted in BIOS, with only the latest BIOS version being installed. Everything is at default settings.
    I’m aware that the Ryzen throttles the RAM to 3600MHz when 4 slots are filled, but unless having the default “Auto” that’s selected in BIOS for Memory Speeds is the culprit (as opposed to manually selecting 3600MHz) I don’t think this is an issue, as read in the FAQ re: Multi-Channel Modules Installed.

    With the Kingston RAM, I am running MemTest86 (not yet complete) and have 19 failures all on Test 8. (See screenshot)

    I will let it finish, but clearly something afoot.

    Is it simply a case of 7950x, AM5, DDR5 are still too bleeding edge and therefore instabilities are expected?

    I have a replacement Ryzen 7950x standing by, just in case of DEFCON1.

    Thanks in advance.​

  • #2
    QVL lists are more of suggestions. I've never followed them, as they are often poorly maintained and out of date. The original RAM should have worked.

    Once Memtest86 has reported one or two errors there isn't much point waiting for it to finish. Even a couple of errors is bad.

    You could try running just two sticks at a time. You might find the error is just 1 slot, or only when you have 4 slots populated (e.g. too much current / voltage drop with 4 sticks). But otherwise it is probably trial and error swapping out the CPU and motherboard.

    > instabilities are expected?

    If they advertised the motherboard and CPU as supporting 128GB, then it should have been well tested before the release. So instabilities are not to be expected.​​


    • #3
      Thanks, David.

      The test finished with 34 errors all on Test 8 (is there a specific reason for test 8 being the one it fails on?).

      I’ve got a high-end board arriving tomorrow (my current one is classed as budget, but is still advertised as handling 128gb).

      Most curiously, I changed the memory frequency in BIOS from “Auto” to 3600Mhz (the highest supported by the 7950x for 4-slot occupied).

      Test 8 just passed on the first pass (no errors so far). Coincidence? Remains to be seen.


      • #4
        All 4 passes of the test were successful.

        I believe the manual selection of the frequency is what helped. That said, I don’t like that this was necessary and doesn’t bode well for overclocking and future headroom (potentially).

        So, I swapped out both the Prime X670-P mainboard with a much more expensive ASUS ROG Crosshair Hero X670-E and the 7950x for good measure, and I’m now re-running MemTest with stock BIOS. Will report back with more.


        • #5
          Ok, update for posterity.

          On the new board, the 5600 sticks threw up errors, running default “Auto” settings in BIOS, just like the previous board. I did try selecting 3600 manually, but on the new board it didn’t work out.

          So, having ruled out the CPU and Board, the only option left was returning the RAM kits yet again, but this time getting 4800 sticks instead — Kingston Fury once again (in QVL). It immediately tested stable running all four sticks at default settings. Finally.

          This leads me to believe 128GB of DDR5-5600 just isn’t stable by allowing BIOS to auto configure down to 3600. At least with this config. Assisting the MC by installing a slower kit definitely helped.

          I did try overclocking using the one DOCP1 profile for 4800 (but selecting 4400 in drop-down for increased chances of stability) and immediately got errors in MemTest. I tried 4200, but got Test 8 errors.

          And then I gave up. Overclocking was way too much to ask for, and I knew it!

          Good news though, I’m running 128GB DDR5-3600, stable.