No announcement yet.

Problem with -o format option osfmount

  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with -o format option osfmount


    I have a question. I'm testing the new version of OSFMount and I see that there is a nice option to format newly created ram-disk.
    I use this with my Total Commander to create ram-disks.

    This is how I did it with the "old" 1.5 version -a -t vm -s %2M -m %1
    Format %1 /fs:ntfs /v:RAM-Drive /q /y

    This workt great.

    In version 2.0.1 I'm trying this command -a -t vm -s %2M -m %1 -o format:"RAM-Drive"

    It gives this message :

    C:\Program Files\TotalCmd\Tools\OSFMount> -a -t vm -s 24M -m S: -o format:"RAM-Drive"
    Creating device...
    Created device 0: S: -> VM image

    But no drive is created.
    If I open OSFMount GUI I see the photo.

    What am I doing wrong ?

    Will there be an option to format the drive as NTFS.

    I'm using Windows 10 64 Bit 1709 Build 16299.248
    Last edited by jslegers; 03-14-2018, 12:39 PM.

  • #2
    The minimum size of RAM disk that is supported by OSFMount using the format FAT32 option when mounting must be a minimum of 260MB. This size requirement is specified in the GUI and the release notes, but it seems we neglected to implement the warning in command line. We'll add the warning to command line for next the build.

    Will there be an option to format the drive as NTFS.
    It is something we would like to do and is on the to do list that might be included in future versions, but we don't have a timeline of when it would be implemented.