No announcement yet.

Software test suite.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Software test suite.

    I am tasked with developing a test application that will test a number of CPU modules and PC104 modules these are quite old now and include a Vortex x86 PC104 board (VDX-6353D) and a Arcom ELAN 104NC board. Part of the testing is to fully test the local system memory on each CPU module and also the local serial devices. I plan to use a cross over cable and connect each of the 4 serial ports to each other then write a message out and verify it can be sent and read.

    As for the memory test I found memtet86++5.01, I'm trying to build this in Centos. When I execute 'make' I get:

    rm -f *.o *.s *.iso memtest.bin memtest memtest_shared \
    memtest_shared.bin memtest.iso
    make: *** No rule to make target `head.S', needed by `head.s'. Stop.

    ** Solved!, I re-opened the .tar.gz archive and dragged out the files into the a folder on Centos, then tried again, it worked, must have been how the files were created without the correct permissions.
    Last edited by SPlatten; 11-15-2016, 03:04 PM.

  • #2
    That memtet86++5.01 release isn't our software and is fairly out of date now. (e.g doesn't have native 64bit support, DDR4 support, ECC support, UEFI support, etc..)

    Maybe you can use our serial loop back plugs for testing the serial ports.