No announcement yet.

Canon Network Printer Madness

  • Filter
  • Time
  • Show
Clear All
new posts

  • Canon Network Printer Madness

    I had a Canon MX 870 network printer for several years that I never had any problems with until the print head finally gave up the ghost. So I decided to replace it with a new Canon printer since I have always been a fan of their equipment. I am not an IT guy by any stretch, but usually can do simple networking like connecting to a network. So I looked at the Canon printers and settled on a business class machine, Maxify MB 2720. I read reviews on Amazon which were mixed with a lot of people complaining about network setup. I ignored those thinking that they were just the usual morons who can't really do anything right and ordered the printer. When the printer came I set it up myself using wifi on my previous router a Netgear R6300 v2. I also have most of my house wired for a LAN with a Netgear switch in my basement and 2 hard wired network jacks in each room of the house. Well the printer worked good for a couple of weeks. I fell in love with the speed and print quality. The output of this machine is really far superior to any other printer I have ever owned. Everything worked great for a couple of weeks and then the gremlins started. You would go to print and the printer would be offline. No matter what I did it would not change to online. I was using it from my laptop, my wife was using it from her laptop and I also used it from a desktop in the house and the kids used it from another desktop in the house. Each had varying degrees of issues once this gremlin started at varying times. So the only solution I had was to keep deleting the printer from the devices and printers and reinstall, which would work for a while and then it would go offline again. Sometimes it would not work as the computer just wouldn't see the printer on the network. So my older son set the printer up on a fixed IP address. And that seemed to work for a while. And then it would go offline again. And we would have to do the delete and reinstall routine whenever we needed to print. Then we upgraded our DSL internet from 3.0 Mbps to 15 Mbps which required us to ditch our Netgear router and use the phone company's (Fairpoint Communications) router and modem combo a Smart RG 555AC (no cable TV available here DSL is only game in town). My son again set the printer up with a static IP address of and everything seemed to be working fine again for a few more weeks and then all of a sudden offline again. Sometimes I would plug a network cable into my laptop when I was trying to print and the printer would then go online and let my document print. The last few days my laptop will not print even with the network cable attached no matter what I try. I tried scanning from the printer to my laptop but the printer does not show my laptop in the list of PC's, but my wife's laptop is there. I have tried searching for a solution to this problem, but have not found a reliable answer that works. I tried removing the check for "SNMP Status Enabled" under port configuration as one suggested fix I found, but that did not help. I am really at wits end with this thing. Any suggestions or help would be greatly appreciated.

  • #2
    So this doesn't sound like a problem related to our software or hardware. You might be better off posting in the Canon support forum. It isn't like we are experts in Cannon printers. We don't even own one. Your last post was also off topic. My only comment would be don't use wireless networking. Cable up everything with Ethernet (with a fixed IP for the printer) if you want something reliable.