No announcement yet.

Seagate Firecuda 530 2TB low scores

  • Filter
  • Time
  • Show
Clear All
new posts

  • Seagate Firecuda 530 2TB low scores

    I recently had to replace my Gigabyte Aorus x399 Xtreme and Threadripper 2950x with an Asus WRX80E Sage Wifi and Threadripper 3955wx when the former motherboard failed just outside the warranty period, and I couldn't find a good new replacement. I cloned my Samsung 970Pro 1TB boot drive to a new Seagate Firecuda 530 2TB and hoped for the best. Everything booted fine and the system has been up for a few weeks now. I've updated the firmware and drivers in Windows 11 Pro to reflect the new hardware. When I ran Passmark, all the tests gave the expected results, except the Disk Mark Score, which was 34850. The full test is at
    I wonder what I can do to improve the performance that I am getting from the Firecuda. It is installed in one of the motherboard's m.2 slots. My previous system was pretty much what I would expect across the board.
    Thank you in advance.

  • #2
    That image doesn't have a link attached to it.
    So we can't see the results.

    And 34,850 isn't a bad score relative to typical SSDs.

    There are reports on the net of Win11 hurting SSD performance in some cases. Especially when it is the boot drive.

    At these high disk transfer speeds it doesn't take much at all to loose 1000MB/sec. (e.g. temperatures, M2 slot running at the wrong speed, using PCIe3 instead of PCIe4, etc.., some disk background activity, wrong drivers, etc..)

    See also this page for general performance issues


    • #3
      I tried to amend the post with the link to the test results, but I couldn't because I had to wait for a moderator to approve the post. Here is the link:
      The drive is typically running at 21 degrees C. It is running at PCI-E generation 4 speeds. I tried to update the firmware, but Seagate said it was the latest version. I had an average of 0b read/write in background transfers before the test commenced. If it is a Windows 11 issue, I can live with it for now. I was thinking of getting 4 4TB drives and running a RAID10 with the adapter card that came with my motherboard, but I didn't want to invest potentially $3800 without some idea of what performance I could expect. My previous system to the Threadripper 2950x I had to replace was a dual Opteron 290 / Supermicro H8DC8 system that I originally built in January of 2006 (Opteron 265s at the time) with two RAID10 arrays of IBM (later Hitachi) Ultrastar Ultra320 scsi 15000 rpm harddrives for boot and primary programs, so I am used to having to spend a bit for speed. I added an OCZ Revodrive X2 240GB when that came out, then some 512GB Samsung 840 Pros as time went on. I miss that computer. It lasted me 12 years and 11 months before I encountered a hardware error that caused Windows 7 to shut down to prevent system damage. I went through 4 bad Gigabyte Aorus x399 Xtreme motherboards before finally getting a good one.
      What is your opinion of the Asus WRX80E Sage SE wifi?
      Thanks again. I will check out the page you linked.


      • #4
        It doesn't appear that anything mentioned on that page applies to my case. I guess I will see if it improves at all with future updates to Windows 11. Thanks, David.


        • #5
          There are details here of the Win11 disk performance issues.


          • #6
            RAID is good for data security (but so are scheduled backups).
            RAID doesn't add much to performance if you already have a fast SSD. Might even hurt a bit for some niche test cases as the latency can be higher.

            What is your opinion of the Asus WRX80E Sage SE wifi
            Never used one. So don't really know.
            The other ASUS boards I have used have been OK.