No announcement yet.

Skylake 6700K Underperformance in Passmark, Max Payne 3 running poorly on new build

  • Filter
  • Time
  • Show
Clear All
new posts

  • Skylake 6700K Underperformance in Passmark, Max Payne 3 running poorly on new build

    System specs
    Processor: Intel Core i7-6700K 8M Skylake Quad-Core 4.0 GHz LGA 1151 91W
    Motherboard: EVGA Z170 Classified K 142-SS-E178-KR LGA 1151
    Cooling: Cooler Master RR-212X-20PM-R1 120mm 4th Generation
    Memory: G.SKILL TridentZ Series 16GB DDR4 SDRAM PC4 28800
    Video Card(s): EVGA Geforce GTX 970 04G-P4-3978-KR 4GB
    Hard Disk(s): 2x Samsung 950 Pro m.2 256 GB PCI-Express 3.0 x4 ssd
    Optical Drive: ASUS Black Sata DVD Rom drive model DVD-e818AAT
    LCD/CRT Model: ASUS VG248QE 144hz monitor
    Case: CMStorm Trooper
    Power Supply: EVGA 220-g2-0850-XR 80 Plus Gold 850W
    Software: Windows 7 Professional

    description of problem
    This didn't originally start out as a PassMark problem. I first noticed my computer had a problem when I tried to play Max Payne 3 for shits and giggles to see how many frames per second I'd get on my new build. The game was tanking in the 30-40 fps range, running pathetically in every graphics mode. I tried to see what the temperatures were under load, I did a bunch of benchmarks, basically I have no clue what's wrong and I'm wondering if my CPU is physically broken somehow or if there's something I can actually fix, let alone diagnose what the hell is causing this bad performance. For whatever reason, my PassMark score is half of my friend's 6700k's scores in almost every area.

    Stuff I've tried so far
    Flashed BIOS to the newest version
    Updated Intel chipset drivers
    uninstalled (with utility) and re-installed newest nvidia drivers
    tested with hyperthreading on and off
    tried with bios defaults and tried with selective bios settings such as C-states off
    literally nothing I've done has changed my crappy benchmarks or made max payne 3 run even remotely playable. It's insane, I used to be able to "max" (hehe) that game out on my old i7 sandy bridge and geforce 560 ti. It's absolutely ridiculous that it would get under 100 fps at any point on a skylake 6700k, I'm freaked out wondering if I have a busted CPU or if I just need to RMA this thing.
    I'd really like to try to diagnose and fix what the hell is wrong with it before sending anything back, because I have no idea if it's my motherboard, CPU, whatever, so any help would be much appreciated.

    Benchmark scores
    Unreal 4 Heaven Benchmark Score: 2174
    PassMark CPU score: 7232 (about half of other skylake 6700k scores, including a friend of mine who has the exact same cpu)
    Passmark overall score: 5765.1

    screenshots of information
    CPU temps idle:
    CPU temps under load (with max payne 3 bad framerate):

    Passmark in-depth CPU test results:

    CPU usage and GPU usage under load:

  • #2
    There is a post here with all the common problems and solutions.
    Causes and Solutions for a slow PC

    But I am guessing that your CPU is underclocked. Maybe you played around too much and have disabled turbo mode.