No announcement yet.

DIRECTX 10 Module Won't Run

  • Filter
  • Time
  • Show
Clear All
new posts

  • DIRECTX 10 Module Won't Run

    Performance Test Version: 7.0 (1010 WIN64)
    OS: Windows 7 Professional (64 bit)

    When attempting to run the suite, everything runs through the complex 3D test, then the program hangs on a black screen. If I use the ESC key, the program terminates and closes. Individually, all of the tests run (Standard and Advanced), with the exception of the DIRECTX 10 module. Either the display goes black and hangs, or the Island/Meteor screen appears with the Windows cursor in the center (but still hangs). Again, using the ESC key the application terminates and closes.

    No issues with any other software (games/applications/utilities) have arisen.

    Any thoughts... ?

  • #2
    What video card do you have?
    What video driver version?
    There are very few other DirectX10 games and utilities on the market (as of Nov 2009). All the developers are still using DirectX9 to be compatible with Windows XP. So it is possible there there is a DX10 bug in your video card device drivers but you haven't noticed it up to now.


    • #3
      You are correct, of course.
      It was an nVidia driver issue with my ASUS/nVidia EN9800GT.
      The initial nVidia driver I installed worked.
      Then I made the mistake of installing an "updated" ASUS version.
      The current nVidia beta driver, 195.55, solved the problem.
      Sorry to bother you; I should've been able to ascertain that myself.


      • #4
        Ya, same problem here with my Geforce 7900GTs running in SLI mode. Of course, this card doesn't support DX10 only DX9c. But the screen goes black entiring the DX10 benchmarking phase and the benchmark application appears to hang with the CPU pegged at near 100%. I waited a few minutes and it never recovered.

        Nvidia Driver ver: 196.21
        Windows 7 64-bit