No announcement yet.

Invalid Video Mode - ASUS ATI EAH5770

  • Filter
  • Time
  • Show
Clear All
new posts

  • Invalid Video Mode - ASUS ATI EAH5770

    I just got a new videocard ASUS ATI EAH5770
    When running PerformanceTest 7.0, it says:
    Invalid Video Mode.
    The resolution and color depth you have selected do not appear to be valud for hardware acceleration.
    Please ensure that the correct monitor drivers are installed.
    Also ensure that the most recent video drivers for your graphics adapter are properly installed.

    Switching to the reference rasterizer,
    a softrware device that iomplements the
    Direct3D feature set, but runs very slowly

    What is wrong?

  • #2
    Which test is this for?
    What colour depth are you running your desktop at?
    Which O/S are you using?

    To start with I would suggest checking that you have the latet video card device drivers and the device driver (.inf) file for your monitor.


    • #3
      Originally posted by passmark View Post
      Which test is this for?
      What colour depth are you running your desktop at?
      Which O/S are you using?

      To start with I would suggest checking that you have the latet video card device drivers and the device driver (.inf) file for your monitor.
      1280 by 1024, True Color (32 bit), 60 Hertz
      Windows 7 Ultimate 64 bit
      Video Card drive is up to date, I tried to update my monitor drivers, but couldn't find anything, they're older monitors (I have 2) LG L1922P and HP F1905. Not sure about the .inf file
      I downloaded the trial version, if I clock About in the Help Menu, it says PerformanceTest 7.0 (1019) WIN64
      I was just running the Benchmark Test (Run Benchmark)


      • #4
        I'm sorry, it says "PerformanceTest 7.0 (101 WIN64


        • #5
          A monitor driver supplies configuration information (an .INF file) used by the operating system to implement the Plug and Play (PnP) features of the monitor such as communicating supported refresh rates, screen resolution, and color quality settings to the operating system.

          But most plug and play monitors don't need an .INF file. The O/S can auto detect them and the resolutions they support by transfering the information from the Monitor to the computer via the video cable.

          You can find more details about this in the VESA DDC and EDID standards. See,

          Of course this might not be the problem at all. But worth looking into.

          When you ran all the tests what test did it get to when you saw this error?

          In Windows device manager are your monitors correctly identified? In Windows display manger can you see the correct set of resolutions for your video card and monitors?

          Drive for HP monitor can be found here,

          But it doesn't say anything about Win7 support.


          • #6
            Device manager only sees Generic PnP Monitor for both monitors

            When I right click the desktop and go to Screen Resolution, in the Display box, it does say L1922P and HP f1905 as options with the recommended resolution at 1280 x 1024

            The rest it gets stuck on is "Running Graphics 3D - DirectX 10" (though my video card is DirectX 11 compatible)

            There is no drivers available from the manufacturers, they're both designed to work with the windows native drivers, according to LG and HP

            Thanks for your help. My computer is actually running great, I just want to fix this error and see how the computer rates.


            • #7
              The message you are seeing is a generic message we display when something unexpected occurs. We released a new build of PT today that should also display an error code that we may be able to use to isolate the problem.

              If you could run the new version and tell us the code we can look into this further. (


              • #8
                I have 64 bit windows and I tried to run the 64 bit version and it said "Error, this program can't run on Windows NT" not sure about that so I installed the 32 bit version and it worked.

                It gives me the same Error with the Error Code: -2005530520


                • #9
                  Can you try running each 3d test individually from the menu rather than running them all together as a batch.

                  Also you should be able to re-download and use the new 64-bit build now. There was a problme with the installer that has been fixed.


                  • #10
                    OK I installed the 64 Bit version, it worked.

                    When I go into Advanced, and click the Complex Test, it gives me the same error code, I tried it a few times with clicking Set All, etc. same error


                    • #11
                      That error code represents D3DERR_DEVICELOST, this is quite a common error that occurs in many DirectX apps. The most common cause is when switching into full screen mode.

                      However the fact that we are throwing an error means that it has occured at an unexpected time that we couldn't recover from.

                      As we have had many people with the same video card as you successfully run this test I don't think it is a hardware issue. Most likely there is some other third party software on your system that is interfering with the test.

                      Another thing that might help is disabling one of your two monitors during testing. PT should run fine on multi monitor systems but we have seen some issues with them before.


                      • #12
                        i tried disabling one of the monitors, no luck. I tried disabling all my programs that are running or almost all of them, no luck. I was thinking it would have somethign to do with resolution, Hz, not sure. Everything seems to work fine, but the error will not go away and it's driving me crazy. I tried running the graphics benchmark test, Furmark, and it seemed to work fine....not sure...


                        • #13
                          I ran PCMark05 and i got the following error, I noticed it was similar to the error I'm getting with Passmark performance test, it says:

                          IDirect3DDevice9:Present Failedevice lost (D3DERR_DEVICELOST)

                          Could my hardware be bad?


                          • #14
                            It is not surprising that you see the same problem with other 3D applications. Our code was originally based on the Microsoft example code which all developers have access to.

                            It is possible it is hardware related. But I still think it is more likely that it is something special about setup. Either conflicting software or conflicting hardware.

                            But still, if you have another video card to swap in as an experiment it would be interesting to try it.


                            • #15
                              I had an ATI Radeon x800 and it worked fine prior to installing the new graphics card which is significantly better.

                              As well, I was searching around and someone instructed me to uninstall all ATI stuff, and delete the folder, then reinstall which I did and the Complex 3d test worked, but my score was VERY low, much lower than people who had a worse graphics card. Someone had a ATI 3870 512MB memory, mine is a 5570 1GB memory, they hgot a 76, and I got a 11 another guy had a worse video card too and got a 70.