No announcement yet.

cpu error access violation at 0x7c91084b dual core

  • Filter
  • Time
  • Show
Clear All
new posts

  • cpu error access violation at 0x7c91084b dual core

    New system build

    opteron 165 dual core
    epox 9npa+ sli
    2x512 pc3200 ballistix ram
    evga 7800 gt (single)

    all at stock speeds

    I keep getting error code on cpu test;

    "access violation at 0x7c91084b(tried to write to 0x00030ffc)"

    I am trying to establish a base line before I overclock and to make sure everything is good at stock

  • #2
    There are no known problems like this with the CPU test in PerformanceTest 6.

    I did a search on Google for you using the crash address, 0x7c91084b.

    Many people have this same crash, but none of them with PerformanceTest. So it would seem to be hardware issue.

    Many people suggested a lot of crazy solutions. But in my mind the following sounded the most plausible.

    Quote from,

    I had this same problem about a year ago. I was getting the same error messages you are. I came here a posted the problem and a lot of very knowledgably and extremely helpful people gave me a lot of great advice.

    Unfortunately, none of it worked. I was first told to change memory, then video card, and then drivers and on and on.

    It ended up being an overheaing problem. I had finally given up and took into a shop, and was very embarrassed when the tech said the heatsink was clogged with dust. He also said the fan was not turning at a high enough RPM. He cleaned the heatsink and replaced the fan and it was fixed.

    So, before you trash your system, or start buying parts, checks to make sure you're not overheating. It may be that you have a different problem, but check that first if you haven't already.




    • #3
      I have the exact same problem. I also have a dual core system.

      Athlon 64 X2 3800
      Gigabyte K8N-SLi
      4x512 pc3200
      bfg 7800 GT OC

      I don't get the error under PT 5.0, only 6.0, and only under the CPU tests, not always on the same one.

      I just tested it, and I only get the error when processes is set to 2.


      • #4
        Can you tell me if the crash address is always the same (0x7c91084b)?

        Does it happen if you run the CPU tests one at a time? Which one(s) does it happen on?

        The fact that is appears to be somewhat random while the CPU is under load is an indicator that is could be a hardware issue (e.g. heat) but we are happy to have a look at the software if we can narrow the problem down a bit.

        Dual core systems put out a lot of heat when both cores are running (as would be the case for the CPU test), so you need to check the CPU temps and your cooling. Is this a home built system of brand name Dell, HP, etc.. ?



        • #5
          my error was a 1 time deal and I have not had the issue again,I have ran test multiple times

          however I cant confirm if this was hardware related (i had not changed any settings between failed test and good test)


          software related(had done a boatload of updated and installing in between test)

          also I was prime95 and memtest86 stable before the error and while my chip runs a wee bit warm (51c load) I dont believe that was it

          I have not had any hardware instabillity issues @ all


          • #6
            Prime95 & Memtest86 are a really poor way of testing a modern CPU.

            Both these prgrams only run using a single thread. This means they use a single core of a single CPU when running and will only load your dual core CPU to about 50% capacity!

            It is the same problem with dual CPU, Hyperthreading and dual core CPUs. Prime95 doesn't fully load them. You can see this from the Windows task manager.

            In my case (Dual CPU with HT) Prime95 only puts about 30% load on my CPUs.

            Needless to say running your CPU at 50% is not going to generate maximum heat.

            PerformanceTest on the other hand starts a thread per CPU core & per HT CPU. Putting double the load on your CPU and four times the load on my CPUs.



            • #7

              I opened 2 instances of prime and set affinity to each core, yes 100% load

              memtest is to test the dimms not cpu and it does fine

              I dont know why you seem convienced it was not software related but oh well.

              anyway is my choice for computer related issues, lots of knowledgeable people and great adviceI have my rig running @2.5ghz and the gaming is awesome


              • #8
                > I dont know why you seem
                > convienced it was not software related

                I am not convinced, but it highly likely it is hardware because,

                1) Similar problems were reported by people on the net, not using our software. These similar problems turned out to be heat related.

                2) Software bugs almost always result in a crash that is repeatable. If you perform the same operation twice on the same system, you get the same crash. Of course there are from time to time software bugs that appear more randomly.

                3) We have 2 reports of a problem like this, but about 200,000 other people use the software without getting this error.

                4) In both cases the people who report the problem seem to be building their own PCs (but don't want to come straight out and say it) and obviously want to overlock their CPUs.

                5) After investigating bugs like this for 6 years I feel I am in a position to say that overlockers are more interested in bragging rights," I have my [2.0Ghz] rig running @ 2.5GHz....", than having a perfectly stable system. Many then enter a state of denial if someone suggests their hand built hardware is anything less than perfect. (not to suggest that you would do this). So some very stong proof is required of a software bug before it is worth investigating crashes on overclocked hand built systems.



                • #9
                  first I never said i did not plan to overclock and I see nothing wrong with overclocking !!!!

                  Second I had this issue @ stock speeds and yes I did test my rig @ stock speeds for stability

                  Finally I never said it was not hardware just stating that the problem has not re-occured is all and I have not changed my hardware but I have modified my software


                  • #10
                    have you installed the amd x2 drivers? Updated nforce drivers? there is also the microsoft X2 hotfix, but I have not installed that.

                    Originally posted by jbutler813
                    I have the exact same problem. I also have a dual core system.

                    Athlon 64 X2 3800
                    Gigabyte K8N-SLi
                    4x512 pc3200
                    bfg 7800 GT OC

                    I don't get the error under PT 5.0, only 6.0, and only under the CPU tests, not always on the same one.

                    I just tested it, and I only get the error when processes is set to 2.


                    • #11
                      Yes, there is also the possibility that some device driver provoked the problem. I assumed that when you said there was a software problem you were referring to our PerformanceTest software (which I do not think is the case for this problem).



                      • #12
                        I get the same fault when running with 2 processes. I have used Performance Test alot and like it. I have changed my processor from 3700+ to x2 4400+ and now get same fault as reported in this thread. New installation of Windows. Must be bug in Performance Test.


                        • #13
                          As another customer reported that installing the Microsoft x2 hotfix and updated device drivers fixes the problem. This should be the first thing you should try.

                          Also as other people using other software from other companies have reported the same fault, you should check for hardware problems, e.g. heat problems. This is especially the case if you have just changed CPUs, to a hotter running CPU.

                          Of course there could be a bug in our software, but for the reasons given in my posts above, we still think it is unlikely. (Well unlikely enough that we want to eliminate other possibilities first)



                          • #14
                            I'm also getting this error on my AMD X2 4400 PC!! My PC is running cool (38 deg) and I haven't overclocked it (yet). can you fix this bug in your software please (at least if you want me to purchase it). Have downloaded the hotfix and latest NVIDIA drivers as per your above message - to no avail.



                            Mobo : Gigabyte GA-K8N Pro-SLI
                            RAM : 2 x 1gb Crucial PC3200
                            OS : XP Pro
                            Disk : Seagate 400gb SATA
                            Video Card : GeFORCE 6600 256mb (GV-NX66256DP)


                            • #15
                              access violation at 0x7c91084b

                              For other people who may experience the same problem we have posted some information to help.

                              We investigated the "access violation at 0x7c91084b(tried to write to 0x00040ffc)" reported with some of the PerformanceTest CPU tests (via email communication) and found that the Microsoft Hotfix corrected the problem:

                              If you receive this crash address, please check that you have the latest versions of the files listed (or later versions) in the above Microsoft article (included in XP SP2):

                              Date Time Version Size File name
                              28-Sep-2005 23:35 5.1.2600.2765 134,272 Halmacpi.dll
                              29-Sep-2005 00:02 5.1.2600.2765 2,136,064 Ntkrnlmp.exe
                              28-Sep-2005 23:35 5.1.2600.2765 2,057,344 Ntkrnlpa.exe
                              28-Sep-2005 23:35 5.1.2600.2765 2,015,744 Ntkrpamp.exe
                              29-Sep-2005 00:04 5.1.2600.2765 2,180,096 Ntoskrnl.exe
                              28-Sep-2005 23:32 5.1.2600.2765 30,720 Arpidfix.exe

                              The crash address described in this post is in the Windows system dynamic library ntdll.dll. This problem has only been reported for Dual core systems when (I believe) there are at least 2 PerformanceTest CPU tests running in parallel. Our theory is that PerformanceTest is provoking a bug in one of the Windows system functions in ntdll.dll that is not thread safe (quite possibly QueryPerformanceCounter e.g. By thread safe, I mean if the Windows system function is called at the exact same time and run in parallel on separate CPU's then a bug like the one you see could occur in
                              the library Windows function.

                              Added 11 August 2006:
                              This problem appears to be most common on the AMD X2. The following patch should be applied to AMD X2 systems:

                    ,00.html for the "AMD Dual-Core Optimizer" solution

                              Another update:
                              In PerformanceTest release V6.0 1012 we have worked around the problem. See below.

                              Ian (PassMark)