No announcement yet.

PT 8 build 1003 installed to a USB drive weirdness

  • Filter
  • Time
  • Show
Clear All
new posts

  • PT 8 build 1003 installed to a USB drive weirdness

    I used the install to USB function for first time since PT8 came out and I'm having some strange things happen. The install to USB was done using my PT8 key. The first time I ran PT8 from the key I noticed the DX11 test did not run. So I manually ran the test and got a popup box stating this test will only run during the 30 day demo or something similar. At this point I went to help and about and PT showed as registered as it should. Just for fun I safely removed the USB flash drive and rebooted the PC. Now when I attempt to run the DX11 test from the USB flash drive I get a popup that says the video card does not support DX11 or similar. Well sure it does. An HD 5670 has full DX11 support per AMD. To prove what was happening I installed PT8 build 1003 and it runs the DX11 test just fine.

    OS W7 64 bit SP1

    Main Box*AMD Ryzen 7 5800X*ASUS ROG STRIX B550-F GAMING*G.SKILL 32GB 2X16 D4 3600 TRZ RGB*Geforce GTX 1070Ti*Samsung 980 Pro 1 TB*Samsung 860 EVO 1 TB*Samsung 860 EVO 2 TB*Asus DRW-24B3LT*LG HL-DT-ST BD-RE WH14NS40*Windows 10 Pro 21H2

  • #2
    Two problems here.

    The first I'd thought I'd fixed in the latest build where we weren't copying all the needed files to USB. I added the 'media' folder to be copied but neglected to add the sub folders, where the actual data is. I'll fix this (again) for the next release, but in the meantime you can correct it yourself by copying the media folder and all it's contents from the install directory on the local computer to the USB install folder.

    The second problem, to do with the 30 day demo message, shouldn't have affected the base DX11 test, but if you tried to go the the advanced 3d test window you would have seen this message. This particular bug is causing certain features to be disabled after 30 days even in licensed copies, a certain quirk with the USB install is that the 'time remaining' is flagged as 0 for licensed copies, whereas with local installs this value is still counting down from the point of install (even though it shouldn't affect anything for licensed copies). It's a good thing you've caught this for us in the first month, so we can put out a patch before this starts affecting normal licensed copies, although anyone who hasn't updated to the latest patch will still be affected.

    I'm going to get out a patch today or early next week to address these issues.

    Build 1004 has been released with these fixes implemented.
    Last edited by Michael (Passmark); 10-23-2012, 10:34 PM.