No announcement yet.

MotoX 1st Gen android phone CPU Mark extreme discrepancy with value reported online

  • Filter
  • Time
  • Show
Clear All
new posts

  • MotoX 1st Gen android phone CPU Mark extreme discrepancy with value reported online

    I wanted to be able to use the benchmark data posted on to help me choose my next android phone, but when I tested my current phone (XT1049) the values for the CPU mark are wildly different from the values posted. for XT1049 shows PassMark=2672 and CPU Mark=8108. When I run the Performance app on my phone I get a somewhat reasonable agreement of about 2200 for PassMark, but CPU Mark at 35,000. I ran the benchmark test several times and saw good consistency. Can someone explain to me why there might be such a large discrepancy between my measured CPU Mark and the one posted for that phone? I would greatly appreciate it.

  • #2
    The discrepancy seems to be the different version of the PerformanceTest Mobile being used. The big change is we updated the CPU tests in V2 to use native code (versus running on JVM) and to less of effect added a new single thread test. While we took some efforts to scale the composite marks to the previous version, there was always going to be some extreme outliers. The charts online are a composite of both V1 and V2. If we took away all V1 results, it would remove thousands of models from charts. The change notes for PerformanceTest Mobile can be found here.

    As such we really recommend not to compare V1 to V2 results directly. In PerformanceTest Mobile V2, you can search for other baselines and restrict to results from V2 only. However, looking over the results submitted for XT1049, there are around 50 results using V1 (between 6K-8K for CPUMark) and 2 results that are from V2 with 30K value.


    • #3
      Thank you Richard. I understand. However, I can't find any way to, as you say: "search for other baselines and restrict to results from V2 only" using the Performance Test Mobile app. The splash screen of the Performance Test Mobile app I installed in the last couple of weeks says it is version 2.0.1002. The only place I see to search for baselines is under Manage Baselines -> Downloads - > search, and I don't see any way to filter results by V1 or V2. In fact, when I use that search (in the android app), I don't even find my phone at all (I'm using the search term:"motorola xt1049"). Can you help me figure out how to find the results like you have for my phone (an others).


      • #4
        Sorry for the confusion, the default search setting within the app is to show V2 only. To include V1 results in the search results, you have to check the "In. V1 Baselines" under "Manage Baselines-> Download -> ... " to show all results from all versions.