Announcement

Collapse
No announcement yet.

Setup & benchmark of Silverstone MS12 NVMe enclosure.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Setup & benchmark of Silverstone MS12 NVMe enclosure.

    I bought a Silverstone MS12 NVMe external enclosure and Silverstone ECU06 PCIe Type-C expansion card.

    The included instructions were pretty rubbish. There was some more detail on the Silverstone web site, but still not enough to get a new M2 drive working in the enclosure in Win10.

    The main problem is that Window10 (and 7 & 8 ) don't allow the partitioning of a USB drive, not even to create a single partition. If the drive can't be partitioned, then it also can't be formatted. USB flash drives come preformatted so this isn't a problem. But M2 NVMe drives normally don't come pre-partitioned and formatted.

    So this is what you see when you plug in your new M2 drive via the Silverstone MS12 enclosure. The drive isn't initialized and there no option to fix it.

    Silverstone MS12 failure

    The solution is to use ImageUSB to partition and format the drive.
    Download link is here
    https://www.osforensics.com/tools/write-usb-images.html

    Download the tool, pick the "Reformat" option. Double check you are formatting the correct drive and you are done.

    ImageUSB format M2 NVME USB enclosure


    Once you are done, you can optionally run some PerformanceTest benchmarks to see how fast it really is.
    ("Advanced drive test" under the Advanced menu)

    M2 Drive used in the enclosure was a Kingston NV1 M.2 NVMe SSD 2TB. Empty and formatted with NTFS.
    Test machine was Ryzen 5 5600x, 32GB RAM.
    Initial test below was on motherboard's USB-C port on a ASRock B550M Pro4 motherboard, this is only a 10Gbit/sec port however.

    The advertised speed of enclosure is 20Gbit/sec.
    The advertised speed of the Kingston SSD was ~17Gbit/sec.

    However the best benchmark speed, in the best scenario, is 850MB/sec, which is 6.8Gbit/sec.
    The worst was 21MB/sec, which is 0.17Gbit/sec. This reflects the higher latency compared to an internal M2 drive.

    So not even half the advertised speed (in the best case on ASRock's motherboard USB-C port).

    If I can get the Silverstone ECU06 Gen2x2 (20Gbit/sec) card working I can test again. For the moment however Silverstone ECU06 is failing to detect any drives that are connected to it.

    Benchmark below:

    Benchmark external M2 drive USB-C

    Update:
    So it seems the Silverstone ECU06 might have compatibility problems with some motherboards. It only works in 1 of the 2 I tried and other reviewers reported the same issue.

    When it does work these are the results.

    We are now getting between 0.22Gbit/sec and 11Gbit/sec depending on the test setup. Which still seems a long way from the advertised 17 to 20Gbit/s.


    Click image for larger version

Name:	PerformanceTest-Advanced-Drive-test-20GB.png
Views:	55
Size:	45.5 KB
ID:	50919



  • #2
    So it seems the Silverstone ECU06 might have compatibility problems with some motherboards.
    Update 1: It might be the case that the correct device drivers are not loaded unless the machine is rebooted WHILE the MS12 external enclosure is connected to the machine. Connecting the USB adapter after the machine has already booted seems to fail. Meaning that is doesn't behave like any other USB device on the market.

    Update 2: Behaviour is different when the USB-C cable is flipped!!! This should never be the case as the cable should be reversible. Different LEDs (blue or red) light up on the ECU06 depending on the cable orientation. Or maybe cable was faulty out of the box? We haven't looked too deeply into what impact this has on anything.

    None of this is documented of course. Surely Silverstone came across all these issues during their internal testing?

    Comment


    • #3
      More problems.
      Silverstone ECU06 doesn't detect the removal of the external USB drive. You get this Code 47 warning and a message about being prepared for Safe removal.
      The driver remains in this blocked state and you can't reconnect the drive.

      Click image for larger version  Name:	Removal.png Views:	46 Size:	15.7 KB ID:	51018

      So it looks like the drive can only work once per reboot of the machine (at least in some motherboards). Pretty rubbish product.

      Comment


      • #4
        And more problems.

        When used with a USB3.0 port (type-A plug, 5Gbit/s port) instead of USB-C then performance is truly woeful, but only with some M2 drives.

        Here is the file copy performance with a Kingston NV1 2TB PCIe 3.0 NVMe M.2 2280 SSD - SNVS/2000G. It was insanely slow.


        Click image for larger version

Name:	Kingston-SS.jpg
Views:	62
Size:	50.0 KB
ID:	51456


        Then after replacing the Kingston NV1 with a Samsung 980 Pro 1TB. File copy was 10x faster. But both SSDs should have easily kept up with USB3.0 port speeds (5Gbit/s in theory but around 3.5Gbit/sec in for real life data).

        Click image for larger version

Name:	Samsung-SS.jpg
Views:	40
Size:	50.9 KB
ID:	51457

        But we know the Kingston Drive can do much better on a Type-C port. So it seems to be yet another compatibility problem.
        (we tested on a couple of different motherboards and different USB3 ports and various cables, but result didn't change)

        This makes the Silverstone MS12 NVMe enclosure unusable with the Kingston SSD.

        Comment

        Working...
        X